Results 1 to 9 of 9

Strange

This is a discussion on Strange within the Manual Transmission forums, part of the Drivetrain category; I think my transmission mount may be going out/gone. When I shift hard from 1-2 or 3-4 I hear a ...

  1. #1
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Strange

    I think my transmission mount may be going out/gone. When I shift hard from 1-2 or 3-4 I hear a thud under the floorpan and the low traction light comes on. Any ideas? I remember it going out before, but never the Low traction light coming on. Thx

  2. #2
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Anybody? What else could it be besides the Transmission mount?

  3. #3
    A friggin fish! LOL buswwa's Avatar
    Join Date
    May 2007
    Location
    Vernon, CT
    Posts
    653

    Pewter
    2000 Z28

    stupid ass torque arm?

  4. #4
    Junior Member Kamesense's Avatar
    Join Date
    Sep 2007
    Location
    NY
    Posts
    50

    Pewter
    99 Z28

    I had the same issue when I first bough my Z28, I also noticed that the shifter was leaning WAY to the passenger side when I stepped on it, along with the distinctive "thud."

    I changed to a Prothane poly mount and when i pulled off the stock one (which mine was hollow in the middle), it had a tear on one side. It was also dry rotted (mine sat around for quite awhile before I bought it). After changing it I never got the "thud" again.

  5. #5
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,466

    Red
    02 35th LE Camaro SS

    Could be catching up with the slack in your DS....

  6. #6
    Army of 1 wooddaniel's Avatar
    Join Date
    Nov 2006
    Location
    Alachua, Fl
    Age
    36
    Posts
    1,733

    Ignition Orange/Black
    2008 G8 GT, 98 Z28 383

    Quote Originally Posted by 35th-ANV-SS View Post
    Could be catching up with the slack in your DS....
    Hm. I checked the U joints and they look good... I think it is the mount. I am going to order a poly one, any suggestions?

  7. #7
    Junior Member Kamesense's Avatar
    Join Date
    Sep 2007
    Location
    NY
    Posts
    50

    Pewter
    99 Z28

    I bought a ProThane mount, no complaints so far. It gets a little noisier in the interior with a polyurethane mount though. Install is easy, took about 1/2 hour.

    Its also taken a few track trips and no problems either.

  8. #8
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by wooddaniel View Post
    Hm. I checked the U joints and they look good... I think it is the mount. I am going to order a poly one, any suggestions?
    Do a search on poly trans mounts. Seems like some of them take a little fiddling with to keep the DS angles correct so your DS doesn't vibrate.

  9. #9
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    Quote Originally Posted by buswwa View Post
    stupid ass torque arm?
    This was my first thought....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. STRANGE,STRANGE Trans Ams
    By fbodyNATION in forum Firebird / WS6
    Replies: 4
    Last Post: 08-27-2013, 04:29 PM
  2. strange s60
    By El Toro Loco in forum Drivetrain
    Replies: 50
    Last Post: 11-16-2008, 10:20 PM
  3. strange s 60
    By tomsws6 in forum Drivetrain
    Replies: 0
    Last Post: 05-17-2008, 08:51 PM
  4. strange S60?
    By 0verkill in forum Drivetrain
    Replies: 1
    Last Post: 12-08-2007, 07:39 AM
  5. strange S60
    By 02T/AWS6 in forum Drivetrain
    Replies: 7
    Last Post: 11-14-2006, 05:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •