Page 2 of 2 FirstFirst 12
Results 21 to 33 of 33

Spec 3 problems

This is a discussion on Spec 3 problems within the Manual Transmission forums, part of the Drivetrain category; ok got ya. i go out to asheville and meet up with people there on patten some sat nights. Kinda ...

  1. #21
    Drop&Drag matt evans's Avatar
    Join Date
    Jan 2010
    Location
    clyde nc
    Posts
    287

    black
    02 Z28 and 00 SS

    ok got ya. i go out to asheville and meet up with people there on patten some sat nights. Kinda amusing watching all the people talking trash about each others stuff and half of them dont even know what they got to begin with.

  2. #22
    Member Edward-T's Avatar
    Join Date
    Jun 2011
    Location
    N.C.
    Age
    48
    Posts
    266

    Blue
    2002-WS6

    yea, kids huh? they get something and think its fast not even knowing its really pretty slow, lol
    2011 GS

  3. #23
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by 35th-ANV-SS View Post
    Correct me if I'm wrong Cutlass, but doesn't a bad throw-out bearing make a squealing noise?
    Yes they can. They can also make a rattle noise.

  4. #24
    Member Edward-T's Avatar
    Join Date
    Jun 2011
    Location
    N.C.
    Age
    48
    Posts
    266

    Blue
    2002-WS6

    i will have it checked out, something is making a noise either a spring or a throw out bearing, i thank you guys for your input.

  5. #25
    Junior Member
    Join Date
    Sep 2006
    Location
    New Jersey
    Posts
    87

    Red
    1999 Trans Am

    Having similiar problems after replacing my flywheel, throwout bearing, slave, master, and clutch with a spec stage 3, it likes to make weird noises now and slips in high gear.. never had a problem with my factory piece.. thinking of taking it out and throwing it as far as I can... same it didnt even make it 10k miles.. my factory one was just fine, only replaced it due to my slave cyl pissing all over it..

  6. #26
    Junior Member
    Join Date
    Sep 2006
    Location
    New Jersey
    Posts
    87

    Red
    1999 Trans Am

    Hmm after reading through this again my problem isn't very similar, but very annoying still. This past feb I pulled my tranny out for the first time at 130k when my slave cyl started leaking, for good measure I replaced the entire hydrolic system, a new factory fly wheel, and installed a spec stage 3 kit which came with a new throwout bearing as well as a new pilot bearing. For the first few hundred miles the only way to get the pos to fully release was to mash the pedal as far a humanly possible, after that went away it was fine for a bit. Next annoying thing was it would randomly make a little chirping noise quite often when shifting into higher gears unless you let the pedal out insanely fast.. Eventually it started doing that when starting off in first and most recently started to slip in 4th gear and up. Puzzled I pulled it all apart after work the other day thinking maybe my rear main was starting to leak a little and getting on the flywheel/friction disc, but there was nothing to see. Don't have the spare $$ to replace it this time in the year so I simply put it back togather after giving a light block sanding to the friction disc and cleaning everything up with brake clean.. Problem is still there so I've taken it off the road for the time until I can get the LS7 setup I should have gotten in the first place..

  7. #27
    Member Edward-T's Avatar
    Join Date
    Jun 2011
    Location
    N.C.
    Age
    48
    Posts
    266

    Blue
    2002-WS6

    i feel your pain, no money right now either.

  8. #28
    Drop&Drag matt evans's Avatar
    Join Date
    Jan 2010
    Location
    clyde nc
    Posts
    287

    black
    02 Z28 and 00 SS

    in my ss i have, the clutch springs broke after 3 days of having it. I went back with a stock unit and so far no troubles but next time ill go with a ls7, or depending on the money situation i may go about monster clutch.

  9. #29
    Member Edward-T's Avatar
    Join Date
    Jun 2011
    Location
    N.C.
    Age
    48
    Posts
    266

    Blue
    2002-WS6

    ok, if i am right at 450 to the wheels, what clutch should i get? the LS7 is not strong enough for that, right?

  10. #30
    Drop&Drag matt evans's Avatar
    Join Date
    Jan 2010
    Location
    clyde nc
    Posts
    287

    black
    02 Z28 and 00 SS

    Monster has an awesome deal on there clutchs and good warrenty as well. GM parts direct has a good deal on the ls7 clutch. there alot of threads on here with people that have used it with no problem.

  11. #31
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by Edward-T View Post
    ok, if i am right at 450 to the wheels, what clutch should i get? the LS7 is not strong enough for that, right?
    Yes. You're probably right at or past the LS7 clutch power range.

  12. #32
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    I wouldn't buy a stock GM clutch with that hp.

  13. #33
    Member Edward-T's Avatar
    Join Date
    Jun 2011
    Location
    N.C.
    Age
    48
    Posts
    266

    Blue
    2002-WS6

    yea you guys are right. sorry for the delay but i been hunting for a week and a half, took the car out and it still performs fine and releases well but the vibration and rattle are still there, no matter where the clutch pedal is - in, out or what gear its in for that matter, does it in neutral so i first thought universal but that wouldnt do it in neutral and it sounds like its coming from outside the tranny not inside, now i'm leaning twards a motor mount or tranny mount, this has me stumped, the only constant is it will do it idleing, driving, pedal in or out, neutral, sorry to keep beating a dead horse but here i go again....

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cam Spec Question
    By PFM in forum Internal Engine
    Replies: 3
    Last Post: 09-23-2009, 07:08 AM
  2. SPEC sucks!!!
    By AaBryan in forum Manual Transmission
    Replies: 4
    Last Post: 09-07-2009, 02:14 PM
  3. Spec III+
    By zlizard in forum Manual Transmission
    Replies: 5
    Last Post: 06-14-2007, 05:24 PM
  4. Problems with Spec??
    By 1badassZ in forum Manual Transmission
    Replies: 0
    Last Post: 03-28-2007, 05:11 PM
  5. SPEC and RAM sale
    By FRCBobby in forum Sales and Group Purchases from our Great Sponsors!
    Replies: 0
    Last Post: 11-16-2006, 04:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •