Results 1 to 6 of 6

Pulling 6speed from LT1

This is a discussion on Pulling 6speed from LT1 within the Manual Transmission forums, part of the Drivetrain category; What is the best way to handle this situation? I have the bellhousing off and all the housing to engine ...

  1. #1
    Junior Member
    Join Date
    Mar 2009
    Location
    San Diego
    Posts
    3

    Black
    1996 Z28

    Pulling 6speed from LT1

    What is the best way to handle this situation? I have the bellhousing off and all the housing to engine bolts off(manual tranny). It won't slide off. Is the clutch lever supposed to disengage?

  2. #2
    Senior Member Zboner's Avatar
    Join Date
    Aug 2005
    Location
    cincinnati/northern ky
    Age
    31
    Posts
    9,045

    Black
    99 SS

    the clutch fork is most likely holding it in

  3. #3
    Junior Member
    Join Date
    Mar 2009
    Location
    San Diego
    Posts
    3

    Black
    1996 Z28

    clutch fork

    what is the best way to disengage the clutch fork?

  4. #4
    Visualize°Design°Create SSwt00SS's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, TX
    Posts
    9,287

    '12 Silver SS 1SS
    '00 Black SS #8617

    drop the "f bomb" a few times...



    if i could remember how we did it when i dropped mine, id be helpful here...

  5. #5
    Junior Member
    Join Date
    Mar 2009
    Location
    San Diego
    Posts
    3

    Black
    1996 Z28

    replacing the clutch

    i got the clutch fork off then tranny pulled right off. by the way it's an LT1 with an MM6 tranny. the clutch fork had a clip and a nut holding in in place. so I had a friend assist me get the biggest gap possible enough to shove a box end wrench(after the clip was pryed out of the way) to loosen the nut. It took forever because there is no room but is probably the worst thing to uninstall in the whole process

  6. #6
    Senior Member Zboner's Avatar
    Join Date
    Aug 2005
    Location
    cincinnati/northern ky
    Age
    31
    Posts
    9,045

    Black
    99 SS

    yup I have been there on the LT1, i did mine 2 years ago it totally sucked ass, hope the LS1 install next week for me goes a bit easier

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pulling the trigger!
    By MudStainKILLA in forum Firebird / WS6
    Replies: 75
    Last Post: 07-28-2011, 10:01 AM
  2. Pulling an LS1
    By mrbvlo in forum Firebird / WS6
    Replies: 6
    Last Post: 11-14-2010, 08:41 AM
  3. HELP PLZ!!! wiring pulling
    By JAX04 in forum GTO
    Replies: 13
    Last Post: 07-03-2009, 01:50 PM
  4. What should i be pulling from all of this?
    By gimmeadonut in forum External Engine
    Replies: 8
    Last Post: 12-23-2005, 08:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •