Page 2 of 2 FirstFirst 12
Results 21 to 33 of 33

Is this normal for a new clutch

This is a discussion on Is this normal for a new clutch within the Manual Transmission forums, part of the Drivetrain category; Originally Posted by That Guy 2-1 rev it sky high, dump the clutch = no chatter ... you're welcome ... ...

  1. #21
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by That Guy 2-1 View Post
    rev it sky high, dump the clutch = no chatter ... you're welcome ... lol

    I have been waiting for someone to suggest this. Took quite a while.

  2. #22
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Quote Originally Posted by JwMonE99 View Post
    About a week ago I installed a new brand new Spec stage 1 clutch.
    my car does have a chatter now. Are these normal symptoms are do I have a problem?

    Yes this is normal. (for a SPEC clutch )

  3. #23
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    this is common with the spec's. mine does the same

  4. #24
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Yea spec sucks

  5. #25
    Junior Member
    Join Date
    Jun 2009
    Location
    tinley park il
    Posts
    26

    black
    99 trans am ws6 ram air

    yea i put the spec stage 3+ clutch in my ta ive put 2500 mile and it still chatters everyonce and a while i put new poly engine mounts and it made it less noticable

  6. #26
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Yea bottom line is it was a big mistake to go with spec.
    I told them that their clutch was making a bad chatter and they said it was impossible and wanted to blame it on the flywheel.

  7. #27
    Junior Member
    Join Date
    Jun 2009
    Location
    tinley park il
    Posts
    26

    black
    99 trans am ws6 ram air

    Quote Originally Posted by JwMonE99 View Post
    Yea bottom line is it was a big mistake to go with spec.
    I told them that their clutch was making a bad chatter and they said it was impossible and wanted to blame it on the flywheel.
    same thing happend to me except i neglegted to tell them i bought the spec flywheel and the line went dead when i told them.......

  8. #28
    Something Diabolical... chuckie669's Avatar
    Join Date
    May 2007
    Location
    Houston, Texas
    Posts
    2,677
    2000 C5 Torch Red

    Quote Originally Posted by Cutlass View Post
    Aaaahhh yeah...release the clutch and the car will move.
    Quote Originally Posted by Cutlass View Post
    his nissan has no balls. your LS1 has lots more torque. More power makes it harder to stall the engine.
    Quote Originally Posted by Wesman View Post
    Exactly what I was going to say. A Nissan 240 is a gutless 4 banger. If yo don't rev the piss out of the engine before releasing the clutch, it will stall out.

    In an LS1 car, if you release the clutch to the grab point at idle, the car will start to take off.
    Quote Originally Posted by Hi-Po View Post
    Because you have this
    hahaha

  9. #29
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Quote Originally Posted by chuckunit69 View Post
    same thing happend to me except i neglegted to tell them i bought the spec flywheel and the line went dead when i told them.......
    Those assholes.

  10. #30
    Junior Member Radicalstylerz's Avatar
    Join Date
    Jul 2008
    Location
    Olathe,KS
    Posts
    23

    Black
    2000 Ws6

    i also over 4th of july weekend installed a spec3+ kit in my 00' ws6 also hell o' chatter my entire im talk in entire car shakes the shifter slams back an fourth and my tailpipes slam into my rear bumper dont get me started on the engine bay ... its embarrasing at a stop light to take off an have your whole car shake ... so i contacted the ws6 store where i putchased everything clutch kit spec billet flywheel and new slave cylinder .. they refered me to specs lead tech ... and he blamed it on flywheel not knowing it was there on flywheel so then he back tracked an said 500mile break in but for me to be more aggressive for the remaining 250 miles rev it higher and stay in gears longer prior to shifting although i doubted him ive done it .. and it seems to be working but only drivin 25miles since phone call ... needless to say i wish i woulda known then what i know now ... im not knocking spec.. YET.. but they sure come up with excuses quik and its never thur clutches after 500 miles if same earthchattering ..they want me to take it out and send into them so they can run tests if bad theyll replace it but im still out the damage caused by the clutch... plus anything else during this time ... SO GOODLUCK...

  11. #31
    Senior Junior Member warpwr's Avatar
    Join Date
    Aug 2005
    Location
    S.F. Bay Area
    Posts
    134

    Silver
    2002 SS

    Quote Originally Posted by LETHALxLS1 View Post
    If it doesn't go away after 500 miles -go to a hill and ride the clutch for a few minutes-LOL
    Sometimes you can get a clutch to quit chattering by starting off in high gear and slipping the clutch for a few seconds. Not every time of course but try it once and see if it helps any.
    I had to do that in my truck every once in awhile when the clutch was still new.

  12. #32
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    A few thousand miles later, still got chattering.
    Fucking Spec clutches

  13. #33
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    My Spec Stage 3+ chatters a little on take off most of the time. If I really am careful on RPM and releasing the clutch just right I can get it to not do it. Either way, it isn't that bad.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: is this normal?
    By dav-02ws6-m6 in forum General Help
    Replies: 14
    Last Post: 05-16-2010, 06:53 PM
  2. Is This Normal?
    By bgable in forum General Help
    Replies: 2
    Last Post: 04-29-2008, 06:37 PM
  3. Replies: 21
    Last Post: 12-13-2007, 08:41 PM
  4. LT1 WS6 vs. normal
    By riceslayer302 in forum LT1
    Replies: 14
    Last Post: 06-24-2007, 01:20 PM
  5. is this normal?
    By TA-LVR in forum Stereo and Electronics
    Replies: 1
    Last Post: 02-19-2006, 06:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •