Results 1 to 5 of 5

No Play in Clutch Pedal- Can I adjust it ?

This is a discussion on No Play in Clutch Pedal- Can I adjust it ? within the Manual Transmission forums, part of the Drivetrain category; Hello All, I have an '01 SS with 54,000 miles.I am the original owner and this is the original clutch. ...

  1. #1
    NastySS NastySS's Avatar
    Join Date
    Jan 2006
    Location
    West Chester, PA
    Posts
    160

    Black
    2001 Camaro SS 1LE

    No Play in Clutch Pedal- Can I adjust it ?

    Hello All,

    I have an '01 SS with 54,000 miles.I am the original owner and this is the original clutch. It seems over the past 6 months I have lost the play in the clutch pedal. I know it is supposed to be self adjusting, but it does not start to grab until the pedal is almost all the way out. There is almost no play left in the pedal. The fluid reservoir is full, and no work has ever been done relating to the clutch. Is there a way I can manually adjust the clutch to give me some play and have it start to grab closer to the floor? I fear it might start to slip soon if I do not rectify this situation. FYI.. the clutch is still good, as I can chirp second with no problem. I have never raced the car or dumped the clutch more than approximately 10 times.

    I would really appreciate any suggestions. Thanks.

    Tom

  2. #2
    Junior Member
    Join Date
    Apr 2006
    Location
    arizona
    Age
    31
    Posts
    2

    silver
    2000 chevy camaro

    im new on this site and dont have an ls1 but it sounds like your clutch is just wearing and the more it wears the less play that you have in the clutch eventually it will get bad to the point where you cant take it out of gear. just my .02

  3. #3
    Junior Member
    Join Date
    Mar 2006
    Location
    Sumter, SC
    Age
    43
    Posts
    15

    Navy Blue Metallic
    1999 Camaro Z28

    time for a new clutch.

  4. #4
    NastySS NastySS's Avatar
    Join Date
    Jan 2006
    Location
    West Chester, PA
    Posts
    160

    Black
    2001 Camaro SS 1LE

    HI,
    Thanks for the reply. Are you sure about this? It has 54,000 miles on it, and I have never raced it, and have been really good to the clutch. I can chirp second no problem, it is just that it grabs almost at the very end of the pedal travel. There is no way to adjust it? I looked under the car, under the hood, and under the dash and could not find an adjustment.

    Are you telling me this from experience? I had a '98 Z-28 and sold it with 68,000 miles and did not have this problem. I probably beat that car more than this one. Most clutches last longer than this if not abused and smoked. Please advise. Thanks.

    ANYONE ELSE???????

  5. #5
    Junior Member
    Join Date
    Nov 2005
    Location
    Rogersville,Tn
    Posts
    15

    Black
    2001 Trans Am

    Mine does it too. I'm not the original owner but when I bought mine 2 and a half years ago it was like that. Only raced a handfull of times and can still chirp second. I've just gotton used to it I guess. If you find any info please let me know. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch Pedal Pressure and Smelly Clutch
    By race5050 in forum Manual Transmission
    Replies: 1
    Last Post: 01-06-2010, 06:37 PM
  2. clutch adjust
    By a 2000 camaro ss in forum General Help
    Replies: 5
    Last Post: 05-06-2008, 10:39 AM
  3. Light Clutch Pedal (New Clutch)
    By Rhinohuey in forum Manual Transmission
    Replies: 2
    Last Post: 09-22-2007, 09:51 PM
  4. Light Clutch Pedal (New Clutch)
    By Rhinohuey in forum Manual Transmission
    Replies: 5
    Last Post: 09-14-2007, 03:41 PM
  5. Fading Clutch Pedal with new clutch
    By mrbob2 in forum Manual Transmission
    Replies: 2
    Last Post: 08-17-2007, 06:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •