Results 1 to 6 of 6

Need Help with Clutch Noise

This is a discussion on Need Help with Clutch Noise within the Manual Transmission forums, part of the Drivetrain category; I don't drive my car much anymore but I have noticed in the past few months that sometimes (mainly when ...

  1. #1
    Junior Member
    Join Date
    Dec 2010
    Location
    Upstate, SC
    Posts
    76

    Black
    1999 camaro

    Need Help with Clutch Noise

    I don't drive my car much anymore but I have noticed in the past few months that sometimes (mainly when it's hot) I will be sitting still with the car running and I push the clutch in and after about 5 seconds of holding it in it starts making this whirring clunking sound. I let off the pedal and it stops. I have a monster level 1 clutch with new stock master and slave. These parts were replaced about 1 1/2 years ago.

  2. #2
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    Sounds like mine. I suspect not having full disengagement.

  3. #3
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Agree. You may have air in the hydraulics. You could try bleeding the system, along with the drill mod.

  4. #4
    Junior Member
    Join Date
    Dec 2010
    Location
    Upstate, SC
    Posts
    76

    Black
    1999 camaro

    I have a speed bleeder. I will try bleeding it again. It already has the drill mod.
    1995 Z28 A4: 353 LT1 Heads/Cam/Stall, awaiting !opti or !LT1

    1999 SS M6: Pacesetter Longtubes, SLP 2otl catback, E-cutout, 218/218 .563 .563 112lsa cam, Ls6 injectors, Ls6 intake, 85mm maf, Whisper lid, Pro 5.0, 4.10 gears, UMI sfc, Founders LCA & PHB, Tuned by v8muscle.net

  5. #5
    Junior Member
    Join Date
    Apr 2013
    Location
    Columbus
    Posts
    4

    Silver Metallic
    1999 Pontiac Firebird For

    Clutch problem

    I had the same problem on my Firebird Formula, same year. Turns out it was the release bearing. It kinda made a scratching or grinding sound, hope this helps.

  6. #6
    Junior Member
    Join Date
    Dec 2010
    Location
    Upstate, SC
    Posts
    76

    Black
    1999 camaro

    Thanks guys. I ended up having to replace my clutch since this post and discovered it was another chewed up pilot bearing causing the noise. So in went a bronze bushing!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch Noise?
    By Red4Mula in forum Manual Transmission
    Replies: 0
    Last Post: 01-27-2007, 06:20 PM
  2. clutch or trans noise
    By RARE 99 in forum Manual Transmission
    Replies: 8
    Last Post: 10-18-2006, 04:13 AM
  3. clutch noise
    By Ws6 Love in forum Drivetrain
    Replies: 0
    Last Post: 10-15-2006, 05:17 PM
  4. Noise when clutch is disengaged
    By amit in forum Manual Transmission
    Replies: 2
    Last Post: 05-21-2006, 11:53 AM
  5. Weird noise? Clutch?
    By dkishton1486 in forum LT1
    Replies: 0
    Last Post: 02-16-2006, 08:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •