Results 1 to 17 of 17

Mstr cyl failure than slipping clutch?!?!?!

This is a discussion on Mstr cyl failure than slipping clutch?!?!?! within the Manual Transmission forums, part of the Drivetrain category; Sorry to ask a help question for my first post...but I have been lurking here for years, So...... Well I've ...

  1. #1
    Junior Member
    Join Date
    May 2009
    Location
    Portland
    Posts
    3

    Mstr cyl failure than slipping clutch?!?!?!

    Sorry to ask a help question for my first post...but I have been lurking here for years, So......

    Well I've got a rebuilt master cylinder, a new slave cylinder and a new SS braided clutch line, I've adjusted the pedal rod to master so there's almost no play.
    The clutch play feels great.
    But the frikin engine revs up while giving throttle after the clutch is engaged, and the car starts pulling like I'm slipping my clutch. The strange thing is it seems to catch better at high RPM's-is this consistent with clutch failure?
    I'm used to a failing clutch slipping in higher gears or while really laying into the throttle w good traction, not slipping while casually driving and than grabbing better (but not great) when the rpm's climb.
    I'm still having a hard time believing the clutch (ACT HD) would fail at the same time the master puked, there's only about 5k mi on it....
    Any words of wisdom people?
    TIA.

  2. #2
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Sounds to me like its an engagement issue with the hydraulics not releasing the clutch all the way.

    Where exactly did you adjust the pedal free play?? I don't recall an adjustment - perhaps I just overlooked it. If you adjusted the pedal too tight (no free play) it will ride the clutch, causing the issue you are describing.

  3. #3
    Junior Member
    Join Date
    May 2009
    Location
    Portland
    Posts
    3
    Sorry
    I should have mentioned this was an R154-5 spd transmission.
    It has a pedal to master cyl adjustment.
    I'm going to start pulling the trans today, I keep thinking it's a funked throw out bearing because of the way it has better (not good) engagement at higher rpm.
    Thanks for the effort Wesman/Bandit!

  4. #4
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    some people have put the clutch disk on backwards. that would deff cause it. also, how many times did you bleed the new system?

  5. #5
    Member 6sw00's Avatar
    Join Date
    May 2006
    Location
    N.Y
    Age
    31
    Posts
    282

    black
    2000 trans am ws6

    sorry to get off topic, but i have a stock clutch and a few weeks ago the clutch pedal was just a pedal.. i had to start the car in 1st gear and drive it home in gear at 2am when there was no traffic. i guess its always engaged, but i dont know if its a new clutch i need or something else. anybody have any ideas before i get it towed to a shop??

  6. #6
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by 6sw00 View Post
    sorry to get off topic, but i have a stock clutch and a few weeks ago the clutch pedal was just a pedal.. i had to start the car in 1st gear and drive it home in gear at 2am when there was no traffic. i guess its always engaged, but i dont know if its a new clutch i need or something else. anybody have any ideas before i get it towed to a shop??
    fluid? bleed system?

  7. #7
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by 6sw00 View Post
    sorry to get off topic, but i have a stock clutch and a few weeks ago the clutch pedal was just a pedal.. i had to start the car in 1st gear and drive it home in gear at 2am when there was no traffic. i guess its always engaged, but i dont know if its a new clutch i need or something else. anybody have any ideas before i get it towed to a shop??
    Pedal dropped to floor and no clutch release?? Sounds like the slave cylinder blew out. Is there any fluid in the clutch reservior??

  8. #8
    Member 6sw00's Avatar
    Join Date
    May 2006
    Location
    N.Y
    Age
    31
    Posts
    282

    black
    2000 trans am ws6

    is the clutch reservior the small container with a rubber thing inside of it next to the master cyl? if so then yea it was basically empty and kinda dirty.. what does that mean? the master cyl, was clean and filled.

  9. #9
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by 6sw00 View Post
    is the clutch reservior the small container with a rubber thing inside of it next to the master cyl? if so then yea it was basically empty and kinda dirty.. what does that mean? the master cyl, was clean and filled.
    Ya the little one is for the clutch master, the big one Is for the brakes. If you have no fluid, you slave could have just blown out. You could also have a busted line or bad clutch master cylinder (which is a bitch to get to, it's under the brake booster. Check those things out

  10. #10
    Member 6sw00's Avatar
    Join Date
    May 2006
    Location
    N.Y
    Age
    31
    Posts
    282

    black
    2000 trans am ws6

    yea i got it flat bedded to the shop today. said they will give me a call tomorrow.. hopefully its nothing serious. at least i have an idea of what it could be now.. appreciate the help.. ill keep you updated.

  11. #11
    Junior Member
    Join Date
    May 2009
    Location
    Portland
    Posts
    3
    Quote Originally Posted by Dr.Crash View Post
    some people have put the clutch disk on backwards. that would deff cause it. also, how many times did you bleed the new system?
    The clutch has been in the car for about 8K mi, I bled the hyd sytem until there was no air coming out.
    The clutch pedal is better than it's ever been, I installed SS line and rebuilt the master and put in a new slave, The issue is the clutch slips in modest power application and than seems to grip better when revved higher....I think the clutch is prob just shot (was hoping for a faulty t/o bearing or something like that.)
    Thanks

  12. #12
    Member 6sw00's Avatar
    Join Date
    May 2006
    Location
    N.Y
    Age
    31
    Posts
    282

    black
    2000 trans am ws6

    where is the slave cyl located?? the mechanic told me he had to drop my transmission to get to the bell housing.

  13. #13
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    No inspection plate? I hate having anyone do stuff just from rip offs that have happen to me. I broke a Z bar (83 TA 305 car) once and the ass said I needed a new clutch so he said he installed a new clutch but when I yanked the trans less than 5 months later because of clutch failure again it was not a new clutch. watch out for retards.

  14. #14
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by 6sw00 View Post
    where is the slave cyl located?? the mechanic told me he had to drop my transmission to get to the bell housing.
    If you pull the tranny you can't bleed the slave. The slave is attached to the tranny. You have to do it while they are together.

  15. #15
    <b>"iznuthn"2 a BOSS!</B> IZNUTHN's Avatar
    Join Date
    Aug 2005
    Location
    SF,CA
    Age
    40
    Posts
    84
    Blog Entries
    1

    ONYX BLACK
    02 Z28

    Ready for rebirth

    I've had my car garaged for sometime now and I am ready to have it towed to the shop. I'm about to finally get it fixed and I hope it is the same issue replacing the master and slave cylinder.

  16. #16
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by IZNUTHN View Post
    I've had my car garaged for sometime now and I am ready to have it towed to the shop. I'm about to finally get it fixed and I hope it is the same issue replacing the master and slave cylinder.
    how much are they charging you?

  17. #17
    Member 6sw00's Avatar
    Join Date
    May 2006
    Location
    N.Y
    Age
    31
    Posts
    282

    black
    2000 trans am ws6

    finally got the job done... ls7 clutch kit and replaced the slave and master. set me back 1500. cant say i dont love it so far.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. i think my clutch is slipping
    By V8MUSCLE in forum Manual Transmission
    Replies: 5
    Last Post: 04-09-2010, 03:39 PM
  2. Help: 3-4 clutch is slipping again.....
    By z28punk in forum Automatic Transmission
    Replies: 7
    Last Post: 06-06-2009, 03:44 PM
  3. Is my clutch slipping??
    By GottaHaveLS1 in forum General Help
    Replies: 9
    Last Post: 12-17-2008, 09:17 AM
  4. new clutch slipping
    By JER-SS in forum Manual Transmission
    Replies: 0
    Last Post: 07-21-2008, 07:09 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •