Results 1 to 5 of 5

LS7 clutch kit installed! 56K Warning!!!!

This is a discussion on LS7 clutch kit installed! 56K Warning!!!! within the Manual Transmission forums, part of the Drivetrain category; Here are the picts of my SPEC clutch after removal. I warn small children this is not a pretty site!!...

  1. #1
    Bad habbit- Smoking Fords
    Join Date
    Aug 2005
    Location
    South Florida
    Posts
    198

    Sunset Orange Metallic
    2001 Camaro SS

    LS7 clutch kit installed! 56K Warning!!!!

    Here are the picts of my SPEC clutch after removal. I warn small children this is not a pretty site!!


  2. #2
    The Pulse of the Maggots SicWs6's Avatar
    Join Date
    Apr 2006
    Location
    Fayetteville, NC
    Age
    33
    Posts
    296

    NBM
    1999 Trans Am WS6

    Damn!!!!

  3. #3
    Junior Member Duke of Cruel's Avatar
    Join Date
    Jun 2006
    Location
    sweden
    Posts
    58

    red metallic
    1991 sierra cosworth

    just saw it now, looks like it was out of balance, or greasy fingers.
    DoC
    Last edited by Duke of Cruel; 06-22-2006 at 06:32 PM.

  4. #4
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    i've seen worse, my stock clutch was totally deteriorating @ 85kmiles. i got a spec 3 and probably won't get another as it's just not a street friendly clutch

  5. #5
    Bad habbit- Smoking Fords
    Join Date
    Aug 2005
    Location
    South Florida
    Posts
    198

    Sunset Orange Metallic
    2001 Camaro SS

    My guess was out of balance, since after installation I had a slight vibration in the drivetrain at 2K rpm.
    2001 SS - 430 RWHP 412 RWTQ
    6 spd, FIPK, Corsa exhaust, LS7 clutch, Dart Pro PP LS1 heads, custom 220/224 cam, Kooks LT's. Ported TB, Full suspension, C5 ZO6 brake upgrade.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: T56 Clutch not disengaging after new clutch installed
    By Brownsugar in forum Manual Transmission
    Replies: 6
    Last Post: 09-25-2014, 05:15 AM
  2. tick m/c clutch installed already
    By turyg ls1 in forum Camaro / SS
    Replies: 0
    Last Post: 07-20-2010, 05:26 PM
  3. New Ls7 clutch kit installed
    By SS-Power in forum Manual Transmission
    Replies: 13
    Last Post: 06-11-2008, 04:55 PM
  4. Replies: 21
    Last Post: 12-13-2007, 08:41 PM
  5. just installed my clutch
    By blue02Z in forum Manual Transmission
    Replies: 4
    Last Post: 02-04-2007, 07:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •