Results 1 to 3 of 3

Light Clutch Pedal (New Clutch)

This is a discussion on Light Clutch Pedal (New Clutch) within the Manual Transmission forums, part of the Drivetrain category; After my slave cylinder finally went out on me, I ended up replacing everything...slave, master cylinder, clutch, etc. I haven't ...

  1. #1
    Senior Member Rhinohuey's Avatar
    Join Date
    Mar 2007
    Location
    Glendale, AZ
    Posts
    1,460

    Black
    1999 Trans Am

    Light Clutch Pedal (New Clutch)

    After my slave cylinder finally went out on me, I ended up replacing everything...slave, master cylinder, clutch, etc. I haven't done the drill mod yet, but its definately in the near future. I originally was going to go with the LS7 clutch, but ended up going with the Luk Pro Gold clutch with aluminum flywheel, just becuase I got the whole kit for the same price as the Ls7 kit. The problem is a really light clutch pedal. (Not a sticky clutch pedal) Its light enough that I could set two or three bricks on there and it would go to the floor. (It always returns fine though) I'm about 95% sure I got the system completely bled. A luk clutch should be pretty stiff, right? I wasn't sure if this was a common thing that I don't know about with a new clutch...something about the breakin process or something. Is there anything else that I'm missing that could contribute to a light clutch pedal?

  2. #2
    Formulatastic yellowv's Avatar
    Join Date
    Dec 2006
    Location
    S. Florida
    Age
    39
    Posts
    1,271

    Red
    98 Formula /93 Z28

    If everything is working fine i wouldn't worry about it. A few years ago when I put a McLeod Rev Lok in my WS.6 I couldn't believe how light the pedal was when it was done. But it worked fine and you couldn't get it to slip if you wanted to.

  3. #3
    Senior Member Rhinohuey's Avatar
    Join Date
    Mar 2007
    Location
    Glendale, AZ
    Posts
    1,460

    Black
    1999 Trans Am

    Ok good. Yeah, no signs of slipage, but just an extremely light pedal. Been going for a few weeks now and it doesn't seem to be showing any problems.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch pedal
    By FIREHAWK0078 in forum Manual Transmission
    Replies: 4
    Last Post: 09-03-2012, 02:54 PM
  2. Clutch Pedal Pressure and Smelly Clutch
    By race5050 in forum Manual Transmission
    Replies: 1
    Last Post: 01-06-2010, 06:37 PM
  3. Light Clutch Pedal (New Clutch)
    By Rhinohuey in forum Manual Transmission
    Replies: 5
    Last Post: 09-14-2007, 03:41 PM
  4. Fading Clutch Pedal with new clutch
    By mrbob2 in forum Manual Transmission
    Replies: 2
    Last Post: 08-17-2007, 06:58 PM
  5. low clutch pedal
    By Semperfiws6 in forum Manual Transmission
    Replies: 1
    Last Post: 03-08-2007, 07:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •