Results 1 to 5 of 5

just installed my clutch

This is a discussion on just installed my clutch within the Manual Transmission forums, part of the Drivetrain category; well i just installed my ls7 clutch and flywheel. also a new slave and master with the drill mod. did ...

  1. #1
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    just installed my clutch

    well i just installed my ls7 clutch and flywheel. also a new slave and master with the drill mod. did it all myself with a little help from one of my buddies and just letting ya'll know it was a royal pain in the ass. thanks for listening to me vent.

  2. #2
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    What was so bad?? Dropping and reinstalling the trans?? Thats usually the worst part, the clutch swap itself should be easy. Of course bleeding the clutch system can be a PITA too, if you have to do that.

    Let us know how it is, lots of guys have had good luck with the LS7 clutch kit.

  3. #3
    Senior Member Danger731's Avatar
    Join Date
    Aug 2000
    Location
    Indy
    Posts
    6,712
    Took me 8 hours for mine. PITA

  4. #4
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    yea, getting the trans out was ok, but stabbing it was a diff. story. them master cylinder was a tough too.

  5. #5
    Crusader DarknessLS1's Avatar
    Join Date
    Dec 2006
    Location
    Miami
    Posts
    36

    Black
    2001 Trans Am

    i threaded(only a lil) the long tranny mount bolt to help guide the tranny back in on the bellhousing. slids right in. its alot easier after the first time

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: T56 Clutch not disengaging after new clutch installed
    By Brownsugar in forum Manual Transmission
    Replies: 6
    Last Post: 09-25-2014, 05:15 AM
  2. tick m/c clutch installed already
    By turyg ls1 in forum Camaro / SS
    Replies: 0
    Last Post: 07-20-2010, 05:26 PM
  3. installed my ls7 clutch today
    By WS6S in forum Manual Transmission
    Replies: 8
    Last Post: 01-24-2010, 02:30 PM
  4. New Ls7 clutch kit installed
    By SS-Power in forum Manual Transmission
    Replies: 13
    Last Post: 06-11-2008, 04:55 PM
  5. Replies: 21
    Last Post: 12-13-2007, 08:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •