Results 1 to 7 of 7

Installed MGW, Now Dash Lights Don't Work.

This is a discussion on Installed MGW, Now Dash Lights Don't Work. within the Manual Transmission forums, part of the Drivetrain category; Okay, I have a couple of drives to make in the dark tomorrow, and I will not be able to ...

  1. #1
    Senior Member Naaman's Avatar
    Join Date
    Mar 2010
    Location
    AZ
    Posts
    1,361

    Cayanne
    98 Z28 Vert M6

    Installed MGW, Now Dash Lights Don't Work.

    Okay, I have a couple of drives to make in the dark tomorrow, and I will not be able to get the wiring diagrams till Monday. Anyone know what the cause could be?

    Here are the symptoms:

    When the parking light switch is turned on, the dash light should illuminate, but it does not. Also, the odometer should dim, but instead, it disappears. All the idiot lights work on start up, the turn signals work and the head lights work. Also, when the parking brake is deactivated, the headlights come on as normal (which cases the odometer to disappear, and dash light fails to illuminate).

    I tried disconnecting that wire that hooks up the lights to the parking brake, and the headlights turned on and dash lights did not. I do not know what I did that would have caused this (I unplugged the 12v, and the ash tray light during the swap, but I forgot to plug the ash tray back in during reassembly, so I will try putting that back in tomorrow).

    Anything ring a bell here?

  2. #2
    Senior Member Naaman's Avatar
    Join Date
    Mar 2010
    Location
    AZ
    Posts
    1,361

    Cayanne
    98 Z28 Vert M6

    Holy Crap! I'm looking at AllData and Chilton, and I cannot for the life of me find this circuit...

    EDIT:
    I found that the instrument panel light is connected into the convertible top switch through pin B (lower right corner, second from right). I don't remember seeing anything wrong with that connection, but I did try to unplug it unsuccessfully during the install. The top iteslf still works fine, so it's probably not a bad connector... more to follow (hopefully).
    Last edited by Naaman; 02-27-2012 at 02:04 PM.

  3. #3
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    The only thing I can think of that would affect the lights at all is the parking brake stitch.

  4. #4
    Senior Member Naaman's Avatar
    Join Date
    Mar 2010
    Location
    AZ
    Posts
    1,361

    Cayanne
    98 Z28 Vert M6

    That's what I was thinking, but I can't figure out where the problem is... I'm going to try back probing the B-pin, hopefully that gets me somewhere.

  5. #5
    Senior Member Naaman's Avatar
    Join Date
    Mar 2010
    Location
    AZ
    Posts
    1,361

    Cayanne
    98 Z28 Vert M6

    So, I checked my fuse box, and sure enough, there is a 5-amp fuse specifically for the instrument panel dimmer. I replaced the fuse, hoping that it was the whole problem. So far, so good: the instrument panel lights up when I turn on the headlights, and the fuse has not blown out. I'm guessing that while tinkering around I induced a momentary short and blew the fuse.

  6. #6
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    easy fix, glad you got it working again

  7. #7
    Senior Member Naaman's Avatar
    Join Date
    Mar 2010
    Location
    AZ
    Posts
    1,361

    Cayanne
    98 Z28 Vert M6

    Yeah, me too: my car is whole again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help! Dash lights off & when headlights on radio lights off
    By BlackWS6TA in forum Firebird / WS6
    Replies: 2
    Last Post: 07-20-2012, 11:39 AM
  2. Replies: 0
    Last Post: 09-07-2010, 05:25 AM
  3. Dash Lights
    By SamD_Ind in forum Firebird / WS6
    Replies: 1
    Last Post: 08-05-2010, 11:16 AM
  4. No running lights, dash lights
    By 77k5 in forum General Help
    Replies: 10
    Last Post: 01-07-2010, 12:35 PM
  5. LED Dash Lights
    By OnEbAdReDSS in forum General Help
    Replies: 4
    Last Post: 01-28-2008, 07:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •