Results 1 to 4 of 4

Feedback/vibration through Pro 5.0 ?

This is a discussion on Feedback/vibration through Pro 5.0 ? within the Manual Transmission forums, part of the Drivetrain category; It's been a long time since I've had an aftermarket shifter but I installed my Pro 5.0 a couple of ...

  1. #1
    Junior Member
    Join Date
    Aug 2008
    Location
    Somewhere down in Texas
    Posts
    66

    Black
    1998 Z28 M6

    Feedback/vibration through Pro 5.0 ?

    It's been a long time since I've had an aftermarket shifter but I installed my Pro 5.0 a couple of days ago. It shifts fine, the only real problem I have is that it is so short and I am so use to the factory shifter that I often go a gear too far. I skip shift from 1st to 6th and accidentally hit 5th after 2nd, etc. But I'm getting use to it again.

    My question is, do the rest of you get a vibration and metallic whining/grinding sound through your shifter? I remember having a little with the Hurst and Pro 5.0 that I had years ago but I don't remember it being this noticeable. It isn't excessive and doesn't bother me, I just want to make sure this is normal. I know the factory shifter has the rubber piece mounted in between the upper and lower halves of the handle that I'm sure dampens some of the sound and the Pro 5.0 doesn't, plus the Pro 5.0 is a much thicker sturdier piece, but does it make that much difference?

  2. #2
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    You will definitely get some more noise and vibration than you would with the stock or Hurst shifter, which use a rubber isolated stick to reduce NVH. However, if the vibration is excessive, you may have a bad u joint or out of balance driveshaft.

  3. #3
    Junior Member
    Join Date
    Aug 2008
    Location
    Somewhere down in Texas
    Posts
    66

    Black
    1998 Z28 M6

    I wouldn't consider it excessive. With the radio on you can't hear it, it's just a slight metallic whining that gets slightly louder under heavier throttle. I just wanted to be sure that it was normal. After driving it a little more I think some of the noise is from the stick rubbing on the adjustment bolts. I think I'll try to find some kind of rubber piece to put on the end of the bolts and see if that reduces it any.

  4. #4
    M6 King Hot Black Trans-Am's Avatar
    Join Date
    Mar 2006
    Location
    WI
    Posts
    5,085
    Blog Entries
    1

    09 EclipseGT 75 Chevy 4x4
    2001 Trans-Am 13 F-XT

    Maybe your shift stops are a little to far out. The shift lever shouldn't be resting on them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB LS1 & Need Feedback
    By bigpappy in forum Camaro / SS
    Replies: 8
    Last Post: 01-30-2009, 08:15 AM
  2. Just need some feedback....
    By konigandy6 in forum Camaro / SS
    Replies: 7
    Last Post: 01-08-2009, 11:45 PM
  3. Need some FeedBack, Plz
    By 02blackz in forum Camaro / SS
    Replies: 43
    Last Post: 09-21-2008, 07:18 PM
  4. Feedback on the 05/06 GTO's
    By Tonys99RamAir in forum GTO
    Replies: 40
    Last Post: 03-17-2006, 10:53 AM
  5. My C5 n02 set-up. Feedback??
    By Juiced2000C5 in forum Nitrous
    Replies: 5
    Last Post: 01-03-2006, 04:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •