Results 1 to 8 of 8

Doesnt feel like my clutch is grabbing Help!!

This is a discussion on Doesnt feel like my clutch is grabbing Help!! within the Manual Transmission forums, part of the Drivetrain category; Like the title says, my car doesnt feel like the clutch is grabbing on acceleration. The pedal still feels good ...

  1. #1
    Junior Member nfellman's Avatar
    Join Date
    Sep 2011
    Location
    Mesa, AZ
    Posts
    64

    Red
    1998 Trans Am

    Doesnt feel like my clutch is grabbing Help!!

    Like the title says, my car doesnt feel like the clutch is grabbing on acceleration. The pedal still feels good and firm but the clutch fluid was low, so I filled it up and it helped a little bit but still not grabbing like it used to. So my thought is that there might be air in the system and I need to bleed the system. Does that sound about right? If so, how much of a pain is it to bleed the system? Thanks in advance for the help!

    -Nate

  2. #2
    Senior Member redbird555's Avatar
    Join Date
    Mar 2009
    Location
    pompano beach florida
    Age
    27
    Posts
    1,008
    2002 Camaro Z/28 Pewter

    well if you had air in the system the problem would be the opposite. you would not be able to DISENGAGE the clutch. since you are losing fluid i'm willing to bet it's leaking somwhere and possibly getting on the clutch disk which is causing it to slip. it you can drive the car and go about 50 and put it in 5th and floor it. if the rpms rise and speed seems to lag then the clutch is slipping and its time to pull the tranny.

  3. #3
    Junior Member nfellman's Avatar
    Join Date
    Sep 2011
    Location
    Mesa, AZ
    Posts
    64

    Red
    1998 Trans Am

    See and that is what I thought too!

    Well I just went and drove it in 5th gear and rpms go up and car lags... Looks like Ill be replacing the clutch soon. If there is anyone in AZ that would be willing to help me out with this I can get beer and pizza! haha

  4. #4
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    Add in the airfare and you have a deal.
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

  5. #5
    Junior Member nfellman's Avatar
    Join Date
    Sep 2011
    Location
    Mesa, AZ
    Posts
    64

    Red
    1998 Trans Am

    Quote Originally Posted by 2002ssslp View Post
    Add in the airfare and you have a deal.
    Done! haha that would put me in the same place financially as paying for it to get done

  6. #6
    Senior Member redbird555's Avatar
    Join Date
    Mar 2009
    Location
    pompano beach florida
    Age
    27
    Posts
    1,008
    2002 Camaro Z/28 Pewter

    I'm pretty sure firbird jones is in AZ but idk where though lol. The clutch install really isn't too bad. Be sure to pickup a new gm style slave and pilot bearing. Also don't waste money on buying the 160 dollar gm slave from places. Autozones dura last slave has the SAME part number and is made by the same company but only costs 60 bucks. Just make sure it has made in Mexico and AP stamped into it. I would also look into a new clutch master they're only about 65 bucks and much easier to do when the Trannys out just cheap insurance IMO.

    As far as clutches go I'd look into monster clutches I think their stage 1 or 2 would work great for your setup and both are right around 500 shipped. Doing a clutch isn't hard it just helps to have a buddy to lift the tranny and you also need a good tq wrench

  7. #7
    Junior Member nfellman's Avatar
    Join Date
    Sep 2011
    Location
    Mesa, AZ
    Posts
    64

    Red
    1998 Trans Am

    Just an update but I ended up taking my car into a shop to get the clutch replaced and I went to pick it up on monday and everything was feeling great! Was on the freeway heading to work and there were no problems but as soon as I got off the freeway and was in 1st gear the transmission began to squeal and howl like crazy through 3rd gear. So I called the place to come get my car and figure out what was wrong, well turns out that it was low on transmission fluid... So they are paying for a rebuild! It sucks for them but I am very grateful that they stepped up and admitted their fault and are fixing it.

  8. #8
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Paying for a rebuild for the transmission? I would highly recommend being involved in what parts they use.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. air lid doesnt fit.
    By redtaws6 in forum General Help
    Replies: 4
    Last Post: 07-01-2012, 05:18 PM
  2. Trans am doesnt feel fast
    By blk-ws6 in forum Firebird / WS6
    Replies: 79
    Last Post: 05-28-2008, 07:03 PM
  3. Clutch pedal doesnt quite release..
    By Brad5150 in forum Manual Transmission
    Replies: 4
    Last Post: 04-04-2007, 08:35 PM
  4. This Doesnt Look Right...
    By Tyler_LS1 in forum Appearance Section
    Replies: 11
    Last Post: 10-01-2006, 11:45 AM
  5. funky clutch feel
    By SilverBelter in forum Manual Transmission
    Replies: 5
    Last Post: 03-06-2006, 08:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •