Results 1 to 4 of 4

cluth problem??? transmission problem???? please HELP!!!

This is a discussion on cluth problem??? transmission problem???? please HELP!!! within the Manual Transmission forums, part of the Drivetrain category; I have a 97 trans am aftermarket stage two clutch,I don't know what's going on. my trans is shifting fine ...

  1. #1
    Junior Member adamblake97's Avatar
    Join Date
    Apr 2014
    Location
    southaven,ms
    Posts
    10

    silver
    1997 trans am

    cluth problem??? transmission problem???? please HELP!!!

    I have a 97 trans am aftermarket stage two clutch,I don't know what's going on. my trans is shifting fine but once in gear and this is through every single gear when I get on it real hard is just redlines IN GEAR! it feel almost like the tires are spinning in the back and I have hardly ANY acceleration. is this a transmission problem? or clutch problem? my clutch has been acting weird every time I let of the clutch and drive it smells like a burning clutch smell but I'm not burning my clutch trust me. something is wrong, please someone tell me what they think this is.

  2. #2
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    Sounds like the clutch is too loose. You have to look at what you installed. Did you surface the flywheel? Did you install a spacer? Did you get the right clutch?

  3. #3
    Senior Member redbird555's Avatar
    Join Date
    Mar 2009
    Location
    pompano beach florida
    Age
    27
    Posts
    1,008
    2002 Camaro Z/28 Pewter

    Quote Originally Posted by az gt eater View Post
    Sounds like the clutch is too loose. You have to look at what you installed. Did you surface the flywheel? Did you install a spacer? Did you get the right clutch?
    What do you mean by too loose? If he torqued everything down it should be loose on the flywheel and if it was would make some awful noise. Op said in another thread he resurfaced the flywheel. Also apparently has 7k on the clutch so it should be the right one. A slave shim or spacer would only cause issues with it disengaging as it wouldnt push the PP far enough in. OP says its a spec unit which are known to sometimes have issues, clutch is slipping plain and simple. whether its caused by a bad PP failing disk or flywheel is something hes going to have to pull the tranny and see

  4. #4
    Junior Member adamblake97's Avatar
    Join Date
    Apr 2014
    Location
    southaven,ms
    Posts
    10

    silver
    1997 trans am

    yea my clutch is slipping bad, coleman taylor is gonna pull out the trans and see what's wrong but the thing is i wanna know if it could be slipping for a simple reason like alignment or a bearing. or if i need the whole clutch replaced and resurfaced flywheel

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Transmission Problem
    By Sickls1 in forum Manual Transmission
    Replies: 22
    Last Post: 05-03-2011, 09:06 AM
  2. cluth or tranny problem? Help.....
    By JD_Z28 in forum Manual Transmission
    Replies: 2
    Last Post: 07-18-2006, 08:57 PM
  3. need serious help with my transmission problem
    By degenerate in forum Manual Transmission
    Replies: 3
    Last Post: 05-15-2006, 08:18 AM
  4. Transmission problem :(
    By LSWONZ28 in forum Drivetrain
    Replies: 7
    Last Post: 02-24-2006, 06:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •