Results 1 to 4 of 4

Clutch rubbing sound when pressed when I start to slow down

This is a discussion on Clutch rubbing sound when pressed when I start to slow down within the Manual Transmission forums, part of the Drivetrain category; Let me start this off by saying I don't know all that much about transmissions just enough to get by. ...

  1. #1
    Junior Member Redskin1's Avatar
    Join Date
    Sep 2010
    Location
    Washington
    Posts
    13

    Navy blue metallic
    2002 Trans Am WS6

    Clutch rubbing sound when pressed when I start to slow down

    Let me start this off by saying I don't know all that much about transmissions just enough to get by. My problem started Thursday when coming to a stop sign I pressed the clutch and I heard a sound that at first I thought was grinding,(but more of a metal on metal rubbing) before I took it out of gear. I thought I probably just needed to bleed my clutch or and more fluid or both. Did it today when I put my exhaust on opened the reservoir and the fluid was black, I mean like a new shade of black. I flushed the fluid and bled it with a mityvac. But it still makes this rubbing sound when I start to slow down and its still in gear. I tried searching but no one really has had the same problem but maybe I just don't get really understand what it is. Maybe I didn't bleed the clutch right or maybe my clutch rotor is warped. Any opinions are welcome I just hope it's nothing to serious.

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    2 things pop into mind.
    Is it the brakes making noise, maybe?
    Or it could be the throwout bearing. If bad, the throwout bearing will make a metallic rattle/grind noise everytime you push the clutch pedal down.

    If neither one of those seems to fit the noise, then we may need more info like where is the noise coming from (front, rear, middle of car. Right or left side or middle)

  3. #3
    Junior Member Redskin1's Avatar
    Join Date
    Sep 2010
    Location
    Washington
    Posts
    13

    Navy blue metallic
    2002 Trans Am WS6

    It's not the brakes its definetly coming the transmission, and it happens when I press the clutch. So it might be the throwout bearing from what your saying.

  4. #4
    Junior Member wildbanshee's Avatar
    Join Date
    Apr 2008
    Location
    florida
    Posts
    68

    pewter
    2000 camaro

    pretty close to my situation...thought i had a belt slipping...it went away after a few days...then after a long road trip it began making unwordly sounds. Have the ls7 clutch on the way...they are a lot more expensive then what i thought..for sure...
    good luck...
    banshee out..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. grinding and rubbing sound !?
    By homerunhtr21 in forum External Engine
    Replies: 11
    Last Post: 09-11-2014, 03:40 AM
  2. Rubbing is not a cool sound
    By LSCyaL8R in forum Wheels and Tires
    Replies: 2
    Last Post: 10-02-2009, 12:56 PM
  3. 95Z slow to start
    By retriever in forum LT1
    Replies: 7
    Last Post: 06-08-2008, 09:37 AM
  4. revs jump+stay at 2500 rpm when clutch is pressed?
    By greatwhiteZ28 in forum General Help
    Replies: 4
    Last Post: 08-08-2007, 07:14 AM
  5. Rubbing sound from engine bay
    By Sk8d85 in forum General Help
    Replies: 2
    Last Post: 02-22-2007, 10:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •