Page 1 of 2 12 LastLast
Results 1 to 20 of 27

clutch questions

This is a discussion on clutch questions within the Manual Transmission forums, part of the Drivetrain category; ok so i have a 99 T/A with the 6 speed ....basicly when i wind it up hard when i ...

  1. #1
    Member unibuga's Avatar
    Join Date
    Aug 2010
    Location
    bacliff,TX
    Posts
    196

    blue
    1999 trans am

    clutch questions

    ok so i have a 99 T/A with the 6 speed ....basicly when i wind it up hard when i hit the clutch it still feels like its grabbing a little and it wont let you shift fast at all ...ive heard of this "drill" mod? could that be the issue....and what is the skip shift light for? and why is there a part to get rid of it? im new to this car so plz help

  2. #2
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,466

    Red
    02 35th LE Camaro SS

    Drill mod is basically only for a "sticky" pedal problem.

    Skip shift light is an "economical" feature car manufactures added which forces the driver to shift from 1st gear to 4th gear. It works off both speed and engine RPM I believe. You will notice once you hit a certain speed or RPM, the skip shift light will turn off which allows you to shift directly from 1st to 2nd gear.

  3. #3
    Member unibuga's Avatar
    Join Date
    Aug 2010
    Location
    bacliff,TX
    Posts
    196

    blue
    1999 trans am

    so do you have any idea on my clutch still feeling like its grabbing when close to redline? its almost impossibe to shift quickly at all making it slower also

    i realize im posting a lot of threads but im new and just have alot of questions

  4. #4
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,466

    Red
    02 35th LE Camaro SS

    Don't worry about asking questions, that is what this site is for

    I am not understanding what you are describing exactly. Are you saying that your pressure plate on your clutch is "not" disengaging from the flywheel? You are saying "grabbing", but that is what the clutches job is. It should constantly be engaged (pressure plate to the flywheel) as long as your clutch pedal is up.

  5. #5
    Member unibuga's Avatar
    Join Date
    Aug 2010
    Location
    bacliff,TX
    Posts
    196

    blue
    1999 trans am

    Like when Im at about 6000 rpm and I depress the pedal I will here the clutch half way Grabbing and it won't let me shift for a sec or two....almost like its not completely disengaging

  6. #6
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Look up info on the Tick Master Cylinder
    pushes more fluid than stock and is supposed to fix your issue

  7. #7
    Member unibuga's Avatar
    Join Date
    Aug 2010
    Location
    bacliff,TX
    Posts
    196

    blue
    1999 trans am

    yeah i was thinkin it was just a lack in pressure

  8. #8
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Quote Originally Posted by unibuga View Post
    yeah i was thinkin it was just a lack in pressure
    before you do anything check the clutch fluid. could be old and dirty fluid

  9. #9
    Member unibuga's Avatar
    Join Date
    Aug 2010
    Location
    bacliff,TX
    Posts
    196

    blue
    1999 trans am

    I checked it and its not low....its my first standard so Idk if its old or dirty

  10. #10
    Junior Member
    Join Date
    May 2010
    Location
    Bentonville, AR
    Age
    37
    Posts
    68

    red
    2002 Camaro SS LE

    Quote Originally Posted by unibuga View Post
    I checked it and its not low....its my first standard so Idk if its old or dirty
    if its black, its old and dirty.

  11. #11
    Member unibuga's Avatar
    Join Date
    Aug 2010
    Location
    bacliff,TX
    Posts
    196

    blue
    1999 trans am

    its dark now ill check it tomorrow....should it be clear? and if its old will it make a big difference?

  12. #12
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,466

    Red
    02 35th LE Camaro SS

    If it is black, change it. Dirty versus clean...

    http://www.google.com/imgres?imgurl=...w=1024&bih=572

  13. #13
    Member unibuga's Avatar
    Join Date
    Aug 2010
    Location
    bacliff,TX
    Posts
    196

    blue
    1999 trans am

    yeah ill have to try that first

  14. #14
    Junior Member
    Join Date
    May 2010
    Location
    Bentonville, AR
    Age
    37
    Posts
    68

    red
    2002 Camaro SS LE

    Quote Originally Posted by 35th-ANV-SS View Post
    If it is black, change it. Dirty versus clean...

    http://www.google.com/imgres?imgurl=...w=1024&bih=572
    wow, great info. what better way to show then in a picture. im gonna check mine tomorrow too.

  15. #15
    Member unibuga's Avatar
    Join Date
    Aug 2010
    Location
    bacliff,TX
    Posts
    196

    blue
    1999 trans am

    so to go about changing it do i do the same as the post you showed me?

  16. #16
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,466

    Red
    02 35th LE Camaro SS


  17. #17
    Junior Member
    Join Date
    May 2010
    Location
    Bentonville, AR
    Age
    37
    Posts
    68

    red
    2002 Camaro SS LE

    Quote Originally Posted by 35th-ANV-SS View Post
    i've also heard, or read that you cold just syphin out what is in the resivour and add fresh?

  18. #18
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,466

    Red
    02 35th LE Camaro SS

    Never heard of that. Everyone here swears by the Mityvac method. It takes little to no time and is the only way to do this hands down.

  19. #19
    Member unibuga's Avatar
    Join Date
    Aug 2010
    Location
    bacliff,TX
    Posts
    196

    blue
    1999 trans am

    still not sure how that little vac thing works

  20. #20
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,466

    Red
    02 35th LE Camaro SS

    It is a vacuum...it sucks it out.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Some Clutch Questions
    By Naaman in forum Manual Transmission
    Replies: 3
    Last Post: 06-05-2011, 05:08 PM
  2. Clutch questions
    By zoomclutch in forum Manual Transmission
    Replies: 5
    Last Post: 01-06-2009, 06:25 AM
  3. Ls7 Clutch Kit Questions
    By Justin93 in forum Manual Transmission
    Replies: 8
    Last Post: 08-14-2008, 12:58 PM
  4. Help Clutch Questions???
    By zlizard in forum Manual Transmission
    Replies: 1
    Last Post: 05-14-2007, 05:33 PM
  5. clutch questions...
    By Labukas19 in forum Drivetrain
    Replies: 9
    Last Post: 10-09-2006, 01:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •