Results 1 to 3 of 3

Clutch question

This is a discussion on Clutch question within the Manual Transmission forums, part of the Drivetrain category; Ok so i got my new ss yesterday from a reputable deler. Heres the problem. Yesterday i decided to really ...

  1. #1
    Member
    Join Date
    Jun 2009
    Location
    Ossian, Indiana
    Posts
    149

    Pewter
    2001 Camaro SS--SOLD

    Clutch question

    Ok so i got my new ss yesterday from a reputable deler.

    Heres the problem. Yesterday i decided to really get on it at a party and it acted "funny" on launch.

    Immediate thought was the clutch was slipping. it was moving forward slowly as if the tires were spinning but did not hear any noise or see any smoke.

    I called a friend back and told me that he saw smoke coming from the tires, but the car smelled like burnt clutch. A friend stopped by with a ws6 and his clutch starts working about two inches from the floor. mine is about 2 inches from the top.

    Is this my clutch going bad?


    History of car was owned by 64 yo man and driven by his 70 yo wife.
    car is a one owner and has 62k miles

    sorry so long all help is greatly appreciated
    Last edited by buzzkill; 06-14-2009 at 09:25 AM. Reason: forgot the mileage

  2. #2
    Every day is a gift-enjoy preston1980's Avatar
    Join Date
    Nov 2005
    Location
    Missouri
    Posts
    716

    Torch Red
    1999 Corvette Hardtop

    Sounds like your clutch fluid was filling up to slowly after you reved it up and popped the clutch so your tires would spinn. Sounds like you need a new master cylinder and/or a slave cylinder, I would do the drill mod if I were you. Just do a search on drill mod and you will know what Im saying. i hope you didnt burn up your clutch to bad. Next time you dump the clutch and dont feel/hear your tires spinning, let up on the gas pedal right quickly.

    It is possible that bleeding your clutch might help. But probally need some hydralic parts (slave cylinder, master cylinder)
    Last edited by preston1980; 06-15-2009 at 12:39 AM.

  3. #3
    Member
    Join Date
    Jun 2009
    Location
    Ossian, Indiana
    Posts
    149

    Pewter
    2001 Camaro SS--SOLD

    thanks i will look into the drill mod.

    had the car checked out and all is good. went back and there were marks on the road from the tires.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: clutch question?
    By BADHAWK209 in forum Manual Transmission
    Replies: 1
    Last Post: 01-12-2011, 08:11 PM
  2. Clutch question
    By Badazz Z28 in forum Manual Transmission
    Replies: 2
    Last Post: 01-04-2011, 02:17 PM
  3. clutch question
    By WS6S in forum Manual Transmission
    Replies: 10
    Last Post: 01-10-2010, 02:36 PM
  4. LS7 Clutch Question
    By 2000sscamaro in forum Manual Transmission
    Replies: 1
    Last Post: 03-27-2007, 06:21 PM
  5. clutch question
    By 98silveraptorhoodws7 in forum Western Members
    Replies: 6
    Last Post: 10-14-2006, 05:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •