Results 1 to 2 of 2

Clutch problems!

This is a discussion on Clutch problems! within the Manual Transmission forums, part of the Drivetrain category; As of a few days ago, I started hearing some rattling only when pressing the clutch in. My guess is ...

  1. #1
    Junior Member GungHoPopsicle's Avatar
    Join Date
    Jan 2007
    Nashville, TN

    Arctic White
    '00 Camaro M6 SS #3553

    Clutch problems!

    As of a few days ago, I started hearing some rattling only when pressing the clutch in. My guess is it's probably the throw-out bearing. BUT, on the way home today in rush hour traffic, the car seemed to buck pretty frequently as if I were at an extremely low RPM in first gear or something. This was most notable when I was in first and second gears at a decent RPM but I could even slightly feel it in higher gears. The car's just NOT driving like it should, needless to say. Anyone have any idea what's going on? Problems with the pressure plate perhaps??

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Madison, WI

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Sounds like the throwout bearing is bad. And perhaps the clutch is starting to slip/chatter. You'll probably have to pull the trans out and have a look to really find out whats up. But once your that far, you might as well be putting a slave w/throwout bearing, a clutch/flywheel kit, and a pilot bearing in.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch problems......
    By steve00ss in forum Manual Transmission
    Replies: 1
    Last Post: 08-16-2010, 06:10 PM
  2. Clutch Problems
    By 1SSWFO in forum Manual Transmission
    Replies: 11
    Last Post: 10-06-2009, 07:29 PM
  3. clutch problems
    By barryz in forum Manual Transmission
    Replies: 4
    Last Post: 08-25-2009, 09:43 AM
  4. Clutch problems
    By firebird400 in forum GTO
    Replies: 2
    Last Post: 06-10-2009, 12:15 PM
  5. Clutch or Transmission Problems
    By Nero.Jacinth in forum General Help
    Replies: 0
    Last Post: 04-30-2007, 09:25 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts