Results 1 to 7 of 7

clutch or other trannsmission problem

This is a discussion on clutch or other trannsmission problem within the Manual Transmission forums, part of the Drivetrain category; Ok i have a shifting problem above 4000rpms, when i drive it and shift into any gear under 4k it's ...

  1. #1
    Junior Member dzikusnj's Avatar
    Join Date
    Nov 2009
    Location
    CLIFTON nj
    Age
    32
    Posts
    43

    white
    98 TA WS6

    clutch or other trannsmission problem

    Ok i have a shifting problem above 4000rpms, when i drive it and shift into any gear under 4k it's fine and that when i hit 4000rpms and over my clutch drops to the floor and i cant shift and than it comes back after good few seconds, my master and slave cylinders were change and im still on stock clutch and i have no idea what could be the problem,please help.

  2. #2
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    The system may have to be bled again.

  3. #3
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    Crappy plastic stock master. Look at a Tick master. Way better. Im way happy with it. You can try the drill mod, but that's only a band-aid. get it fixed before you tear your tranny up.

  4. #4
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Agree. It's a problem with the hydraulics.

  5. #5
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Either a leak in the hydraulics or air in the system. (probably indicating a leak)

  6. #6
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    I'd start by checking your hydraulic fluid. How long ago was it changed? Is it honey in color or black? Is it low at all? If it's low, you have a leak most likely and a leak is a key indicator that your slave or MC is going out.

  7. #7
    Junior Member dzikusnj's Avatar
    Join Date
    Nov 2009
    Location
    CLIFTON nj
    Age
    32
    Posts
    43

    white
    98 TA WS6

    no my fluid has changed about 3 months ago and it doesnt go down at all

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. another clutch problem
    By ali pontiac in forum Manual Transmission
    Replies: 2
    Last Post: 09-29-2010, 03:43 AM
  2. LS7 clutch problem.....
    By nmssr08 in forum Manual Transmission
    Replies: 14
    Last Post: 12-16-2008, 05:57 AM
  3. Clutch Problem
    By Blackout01 in forum Manual Transmission
    Replies: 2
    Last Post: 08-07-2007, 03:48 PM
  4. is it a clutch problem, or a tranny problem?
    By sgt0704 in forum Manual Transmission
    Replies: 3
    Last Post: 01-07-2007, 05:03 PM
  5. Clutch problem..help please
    By Scorch in forum Manual Transmission
    Replies: 16
    Last Post: 03-02-2006, 10:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •