Results 1 to 12 of 12

Clutch Not coming all the way back up high rpm's

This is a discussion on Clutch Not coming all the way back up high rpm's within the Manual Transmission forums, part of the Drivetrain category; I just got my 2000 ss camaro I super chipped it I took it out rev her up to 5k ...

  1. #1
    Junior Member Resinblast's Avatar
    Join Date
    Aug 2014
    Location
    Ohio
    Posts
    29

    Black
    2000 SS camaro

    Clutch Not coming all the way back up high rpm's

    I just got my 2000 ss camaro I super chipped it I took it out rev her up to 5k lil more shift the peddel didnt come all the way back up so I stop the car turned it off pushed it in let off a few times it came back up.... Ive found if I have the peddel engaged and I rev higher rpms it doesnt come back???? 4500 all day np anything over its sticking please give me some advice here I just spent 7k on the car dont have alot left over

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    I'm pretty sure you have the stock MC, Correct? High Rpm, rapid shifts

    "Classic" GM Master Cylinder issues. It's an issue that is with the design of the GM MC.

    There's only 2 fixes.

    Best fix - Order a Tick MC for 4th gens. Not cheap but the best damn MC on the market and worth it's weight in gold.

    Cheap fix but the riskiest - Google drill mod for the 4th gen MC. I say riskiest because if you screw up you are ordering a complete new MC in order to get the hydraulic hose.


  3. #3
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Are you shifting at 5K while driving when you have the problem or are you revving to 5K in neutral and then dumping the clutch?
    It's on jackstands.

  4. #4
    Junior Member Resinblast's Avatar
    Join Date
    Aug 2014
    Location
    Ohio
    Posts
    29

    Black
    2000 SS camaro

    Quote Originally Posted by 35th-ANV-SS View Post
    Are you shifting at 5K while driving when you have the problem or are you revving to 5K in neutral and then dumping the clutch?
    1st gear to 2nd at 5k rpms already moving
    Last edited by Resinblast; 08-11-2014 at 02:38 PM.

  5. #5
    Junior Member Resinblast's Avatar
    Join Date
    Aug 2014
    Location
    Ohio
    Posts
    29

    Black
    2000 SS camaro

    SMWS6TA thanks for the info sir

  6. #6
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    OK. Just checking. Then I'd follow what Scott posted. Let us know what you find.

  7. #7
    Junior Member Resinblast's Avatar
    Join Date
    Aug 2014
    Location
    Ohio
    Posts
    29

    Black
    2000 SS camaro

    Sigh now I got another problem lol my security light is on and sometimes wont let me start my car

  8. #8
    Senior Member theorangeguy's Avatar
    Join Date
    May 2013
    Location
    Nashville, TN
    Posts
    1,434

    Black / White
    '00 T/A M6/'15 Hemi Truck

    Quote Originally Posted by Resinblast View Post
    Sigh now I got another problem lol my security light is on and sometimes wont let me start my car
    Did you just buy this car...? Security light can be fixed with a vats bypass but it sounds like you are having quite a few issues with it at the moment.
    2000 Black TA M6 - LT's, ORY, UMI Short Stick, TT2's, Drilled/Slotted Rotors, Braided Lines, and Tuned by Vengeance SCCA and Car Show Approved
    2015 Ram 1500 Crew Cab Sport Premium Hemi
    2010 Hemi Crew Cab Sport Premium - Tuner and HID's - Sold
    06 Quad Cab HHHHemi - Sold
    99 Hugger Orange Camaro - Sold
    97 Camaro - Sold

  9. #9
    Junior Member Resinblast's Avatar
    Join Date
    Aug 2014
    Location
    Ohio
    Posts
    29

    Black
    2000 SS camaro

    Yeah 2 weeks ago then this friday I tryed to start my car the security light was blinking made me wait like 5mins to start it... Now the light stays on but starts right up

  10. #10
    Senior Member theorangeguy's Avatar
    Join Date
    May 2013
    Location
    Nashville, TN
    Posts
    1,434

    Black / White
    '00 T/A M6/'15 Hemi Truck

    Quote Originally Posted by Resinblast View Post
    Yeah 2 weeks ago then this friday I tryed to start my car the security light was blinking made me wait like 5mins to start it... Now the light stays on but starts right up
    Usually the cause of the security light is the deterioration of the wires in your column...it's a very common problem and most Fbody owners have to deal with at one point or another. The vats bypass allows you to trick the system into thinking that it's reading the key even though it isn't. One thing I would recommend doing is cleaning your key and the resistor in your key with rubbing alcohol. Believe it or not, dirt and grease on your key can cause the security issue...I've had it happen. Either way, the bypass will more than likely have to be done to fix the issue.

  11. #11
    Junior Member Resinblast's Avatar
    Join Date
    Aug 2014
    Location
    Ohio
    Posts
    29

    Black
    2000 SS camaro

    Yeah ive cleaned the key and used my back up one still samething.. Ill have to look into the bypass and the drill out mod for my MC Thank you for your help

  12. #12
    Senior Member theorangeguy's Avatar
    Join Date
    May 2013
    Location
    Nashville, TN
    Posts
    1,434

    Black / White
    '00 T/A M6/'15 Hemi Truck

    Quote Originally Posted by Resinblast View Post
    Yeah ive cleaned the key and used my back up one still samething.. Ill have to look into the bypass and the drill out mod for my MC Thank you for your help
    No problem. I'm on my phone right now but I can get you a link for the bypass tomorrow morning.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Coming Back!!!
    By LT1 Hawk in forum Western Members
    Replies: 2
    Last Post: 03-17-2013, 03:45 PM
  2. Coming back to the V8 world
    By Oliver in forum New Member Introductions
    Replies: 2
    Last Post: 02-25-2009, 08:02 PM
  3. Coming Back...
    By 3spride in forum New Member Introductions
    Replies: 2
    Last Post: 11-21-2007, 11:40 PM
  4. Weird Lights coming in at high RPM
    By jwindbigler in forum Western Members
    Replies: 8
    Last Post: 12-31-2006, 05:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •