Results 1 to 2 of 2

Clutch issues

This is a discussion on Clutch issues within the Manual Transmission forums, part of the Drivetrain category; My 1st post here... I have a 01 camaro ss manual with some clutch issues I'm trying to diagnose. Bought ...

  1. #1
    Junior Member
    Join Date
    Dec 2015

    Clutch issues

    My 1st post here... I have a 01 camaro ss manual with some clutch issues I'm trying to diagnose. Bought the car this summer... Had 50k miles I've put 5k on this summer. I had a mushy clutch pedal a few months after I bought car. I ended up using a brake bleeder to attempt to suck any air out of the lines. This seemed to work as the pedal was firm for another month or so. One night I hammered on the car pretty good and ever since if I engage clutch for a period of time ( example sitting at a red light engaged in 1st gear) the clutch smells. Doesn't smell like a burnt clutch more like clutch fluid itself. Drives fine without any noticeable slipping. No leaks... Any symptoms sound familiar? Not sure if it's clutch, master, or slave. Any help would be greatly appreciated... Thanks!

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Ugy Lower Corner of AL

    Navy Blue Metallic
    98 T/A w/a little mods...

    Sounds like you may have glazed over the flywheel. It's in the beginning stages of beginning to slip.

    Mushy pedal is common with the OEM Master. Really noticeable on high rev, rapid shifts like say at a track. Tick Performance has the best Master out there. Kinda pricey when compared to OEM but soooooooo worth it.

    If you get to the point you need to look at replacing the clutch look for LS7 clutch kit. For stock & mild bolt on's it's a good kit. I ran it till I past it's capabilities.

    6.0L Block - Forged 403 built, breaking it in , Polluter Stg3 Cam, FAST 102mm Intake, NW102 TB, MSD wires, NGK TR6 plugs, Truck Coil Packs, LS3 Fuel Injectors, CC Pacesetter LT Headers, TS&P ORY, QTP e-Cutout, Magnaflow Muffler, SLP Air Lid & Line Lock, Catch Can, Stage 2 T56, PRO 5.0 Shifter, Tick MC, Monster Stg 4 Clutch, QT SFI BH, MWC DSL, UMI: SFC, PHB, LCA's, LCA Relocation Brackets & TA, Hotchkis Springs (1" Drop), YR1 Snowflake Wheels wrapped in NT555 tires & Custom Fab Ford 8.8 rear w/4.10 Yukon Gears, WSQ Hood, 3"CM Strange Eng Drive Shaft.

    Horsepower never lies, but is often lied about!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch issues.
    By SilverBulletLS1 in forum General Help
    Replies: 6
    Last Post: 11-20-2013, 06:10 PM
  2. clutch hyd issues
    By werewolf in forum Manual Transmission
    Replies: 19
    Last Post: 12-28-2011, 03:18 PM
  3. LS7 clutch issues
    By rabiddog in forum Manual Transmission
    Replies: 3
    Last Post: 11-29-2009, 02:35 PM
  4. Clutch Issues
    By BirdCountry02 in forum Manual Transmission
    Replies: 5
    Last Post: 07-30-2009, 05:32 PM
  5. CLUTCH issues..
    By foxman92 in forum Manual Transmission
    Replies: 33
    Last Post: 07-19-2009, 10:40 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts