Results 1 to 3 of 3

Clutch engages w/o pedal when I give it gas

This is a discussion on Clutch engages w/o pedal when I give it gas within the Manual Transmission forums, part of the Drivetrain category; The problem I am having is the clutch engages at low rpms (2-3000) when I give it gas when my ...

  1. #1
    Member
    Join Date
    Jan 2006
    Location
    houston
    Posts
    205

    Navy Blue
    ls1 trans am

    Clutch engages w/o pedal when I give it gas

    The problem I am having is the clutch engages at low rpms (2-3000) when I give it gas when my foot isnt even on the pedal. Almost as if the clutch is slipping. However, it engages fine when I shift and doesnt slip. It has been progressively been doing this more recently. Mainly in gears 4,5,6. When I give it gas the engine revs up and I can tell the clutch is engaged.

    The clutch is a star spec III ceramic disc and as always chattered like crazy in first gear. I had MTI install the clutch.. so Im sure the install was done right. I dont race it anymore and drive it pretty easy. I hope its not the clutch slipping b/c this is the 2nd clutch I have put in it. MTI told me that chatter is normal in 1st gear even after break in. Any thoughts? Thanks

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Sounds like the clutch is going. In those gears there is more strain so that is why you notice it. You could also try to be easy on it for a few miles, it could be that the disc is slightly glazed.

  3. #3
    Member
    Join Date
    Jan 2006
    Location
    houston
    Posts
    205

    Navy Blue
    ls1 trans am

    Yeah I can tell now that it is the clutch. Im surprised that a Spec III ceramic disc is worn out when I dont race it or heat my tires up. Is it a worn clutch or could something else have gone bad that is causing this? I really dont want to fork out the money for a new clutch. paid 1200 for this one. Thanks guys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. clutch engages low
    By RedHot99T/A in forum Manual Transmission
    Replies: 2
    Last Post: 02-20-2011, 04:36 PM
  2. Clutch Pedal Pressure and Smelly Clutch
    By race5050 in forum Manual Transmission
    Replies: 1
    Last Post: 01-06-2010, 06:37 PM
  3. Light Clutch Pedal (New Clutch)
    By Rhinohuey in forum Manual Transmission
    Replies: 2
    Last Post: 09-22-2007, 09:51 PM
  4. Light Clutch Pedal (New Clutch)
    By Rhinohuey in forum Manual Transmission
    Replies: 5
    Last Post: 09-14-2007, 03:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •