Results 1 to 6 of 6

BAD! Violent shuddering and shaking with new clutch HELP!

This is a discussion on BAD! Violent shuddering and shaking with new clutch HELP! within the Manual Transmission forums, part of the Drivetrain category; ...

  1. #1
    Insane WinSomeLoseNone's Avatar
    Join Date
    Dec 2005
    Location
    PA - Montgomery County
    Posts
    185

    Black
    2000 Camaro Z28 M6

    BAD! Violent shuddering and shaking with new clutch HELP!

    I think I screwed up. Yesterday I installed a rebuilt trans, Spec 3+ clutch, Cut stock FW, Ram adj. master, and Ram slave. The install went smoothly, however when I tested the clutch everything went to hell.

    In neutral with the clutch out where is no problem, in first with the clutch depressed sometime there is slight vibrations and shuddering. When I start to release the clutch in first all hell break loose. There is pretty violent shuddering and shaking, but when it is fully engaged everything is smooth and perfect and I can shift through all 6 gears easily. The only time that I have shuddering is moving from a stop and if I shift the slightest bit slowly it shudders.

    ALSO** when I partially engage the clutch in first from a stop it sounds like its partially contacting, like a quick tapping almost. Iíve driven well over 100,000 miles in a stick and know what it feels like when you donít start correctly and you shudder and this is completely different, it is MUCH more violent and uneven.

    The fact then when partially released it only contacts in certain places seems like something is not spinning correctly, almost lopsided spinning causing the shuddering. I did not have the clutch and PP balanced with the FW because the guy at NAPAís machine shop told me that ls1ís have internal balancing in the motor and I have to pull the motor to balance the FW and PP with the motor, and if he balanced them then the motor would be all out of wack. Is this true???

    PLEASE im close to suicide after all the time and money I have put into this.
    What do I do.

  2. #2
    Member SSpdDmon's Avatar
    Join Date
    May 2006
    Location
    Farmington, MI
    Age
    38
    Posts
    332

    SOM
    '01 Camaro SS

    Increased clutch chatter is normal with an aftermarket clutch - especially one of the stronger ones like the 3+. Although, it's hard to say having not seen your car whether or not what you're seeing is 'normal' or not. I'm assuming you got the puck design? My guess is that clutch grabs like a MoFo and you trying to slip it to get the car rolling in first is going to cause the chatter you're feeling. Hopefully, you upgraded the slave cylinder while you were in there too.

    My suggestion (since you said it was shaking a little with the clutch depressed) would be to adjust the master cylinder out a touch. Full engagement should be closer to the top of the pedal's travel - not right off of the floor.

    As for the balancing, I don't recall having to have my clutch balanced when we did the install in my '99. Then again, I bought the LS6 clutch, FW and PP package from GM. If anything, the machine shop should have balanced the FW after they cut it...or cut it to be balanced. If things were out of balance, the shaking would get progressively worse as the RPM's rise while the clutch is engaged or disengaged.

    Adjust the master and get through the break in period. It should get better with time.

  3. #3
    Junior Member
    Join Date
    Dec 2005
    Location
    Ms
    Posts
    57
    I put the Spec 3+ in my car with a billet steel flywheel and left the original master cylinder and slave cylinder in the car and I have never had any chatter out of mine. Even right after the intall. It has got about 5,000 miles on it and still no problems.

  4. #4
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    i have the spec 3 and i had the chatter for about the first 1000-1500 miles. the guys at the shop said that it may happen. who knows

  5. #5
    Senior Member KyleLs1's Avatar
    Join Date
    Aug 2005
    Location
    Canada eh
    Posts
    3,534

    NBM
    99 TA

    i just got a Centreforce DF and im having the same issue, it seems like i have to give it alot more gas to avoid the chatter, then with the stock clutch. it hasnt been as bad after the break in period but it hasnt completely gone away

  6. #6
    Junior Member
    Join Date
    Aug 2006
    Location
    Warwick, Australia
    Posts
    6

    White
    V6 S/C Commodore

    Quote Originally Posted by WinSomeLoseNone View Post
    I think I screwed up. Yesterday I installed a rebuilt trans, Spec 3+ clutch, Cut stock FW, Ram adj. master, and Ram slave. The install went smoothly, however when I tested the clutch everything went to hell.

    In neutral with the clutch out where is no problem, in first with the clutch depressed sometime there is slight vibrations and shuddering. When I start to release the clutch in first all hell break loose. There is pretty violent shuddering and shaking, but when it is fully engaged everything is smooth and perfect and I can shift through all 6 gears easily. The only time that I have shuddering is moving from a stop and if I shift the slightest bit slowly it shudders.

    ALSO** when I partially engage the clutch in first from a stop it sounds like its partially contacting, like a quick tapping almost. Iíve driven well over 100,000 miles in a stick and know what it feels like when you donít start correctly and you shudder and this is completely different, it is MUCH more violent and uneven.

    The fact then when partially released it only contacts in certain places seems like something is not spinning correctly, almost lopsided spinning causing the shuddering. I did not have the clutch and PP balanced with the FW because the guy at NAPAís machine shop told me that ls1ís have internal balancing in the motor and I have to pull the motor to balance the FW and PP with the motor, and if he balanced them then the motor would be all out of wack. Is this true???

    PLEASE im close to suicide after all the time and money I have put into this.
    What do I do.

    How much H/P is your engine producing? if it is under 500hp then you should have fitted an organic clutch plate and not a button or puck type. I recently had a 2000 model in my workshop and replaced the flywheel and clutch and I also fitted a New GTO T56 with ratios of 2.97,2.07,1.43,1.0,.83,.56 ( the original T56 was worn out ) This car drove great and had no shudder or vibrations, the engine produced 430HP. Mal

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ls1 chattering shaking bad! Spec clutch? Ne1 help
    By allformyws6 in forum Firebird / WS6
    Replies: 1
    Last Post: 07-26-2010, 09:59 AM
  2. Shuddering problem
    By Anwazi in forum Automatic Transmission
    Replies: 29
    Last Post: 03-29-2010, 05:11 PM
  3. shuddering while stopped in gear
    By MillerTime in forum General Help
    Replies: 2
    Last Post: 02-20-2010, 07:51 PM
  4. Violent Shaking
    By TheKitchenSink in forum Automatic Transmission
    Replies: 4
    Last Post: 06-13-2007, 09:23 AM
  5. Jerking/Shuddering still
    By freshduckie in forum General Help
    Replies: 18
    Last Post: 04-16-2006, 06:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •