Results 1 to 4 of 4

1998 z28 help

This is a discussion on 1998 z28 help within the Manual Transmission forums, part of the Drivetrain category; I have just recently replaced clutch master cylinder on this car. The slave/TOB/Clutch/PP were replaced around 10k ago by a ...

  1. #1
    Junior Member
    Join Date
    Aug 2005
    Location
    NC
    Age
    35
    Posts
    12

    red
    1998 z28

    1998 z28 help

    I have just recently replaced clutch master cylinder on this car. The slave/TOB/Clutch/PP were replaced around 10k ago by a local shop. After doing the master I have had a little trouble bleeding it, but after a few tries it has very good pedal pressure and engagement points. Now comes the bad part. I have good pedal, but a loud noise coming from the tranny when the clutch pedal is depressed and then a loud pop upon full pedal. Any ideas or opinions? This is my dd. Or if you're local I'll even throw ya some cash if you can fix it. I am tired of bathing in brake fluid. LOL

    Thanks everyone

  2. #2
    Junior Member
    Join Date
    Aug 2005
    Location
    NC
    Age
    35
    Posts
    12

    red
    1998 z28

    Update :

    After pumping the clutch repeatly the POP sound is gone. Now I just have a loud squeak coming from the transmission as I push in or release the clutch pedal. Once again I am not losing any fluid that I can tell and not lost pedal pressure. But this noise is LOUD. any ideas anyone?

  3. #3
    Junior Member
    Join Date
    Aug 2005
    Location
    South Jersey
    Age
    37
    Posts
    17

    NBM
    98 Trans Am convertible

    Sounds like a problem with the slave assembly.

  4. #4
    Junior Member
    Join Date
    Aug 2005
    Location
    NC
    Age
    35
    Posts
    12

    red
    1998 z28

    k, but up until the master, the slave had worked perfectly. and is pretty fresh. so I dunno, but I am open to all ideas

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ISO 1998 trans am , camaro ls ECM and only 1998 ECM for ls1
    By knock0991 in forum Computer & Tuning
    Replies: 2
    Last Post: 07-24-2015, 07:59 AM
  2. 1998 WS6 help please
    By Mike0202 in forum Firebird / WS6
    Replies: 2
    Last Post: 04-23-2009, 04:02 PM
  3. LS2 or LS6 for 1998 TA A4 WS6
    By brian98ws6 in forum Internal Engine
    Replies: 15
    Last Post: 11-18-2007, 04:43 PM
  4. 1998 Red Z
    By LS1Camaro98z in forum Member's Rides
    Replies: 3
    Last Post: 03-24-2007, 11:45 PM
  5. 1998 Ta
    By matt7890_1 in forum New Member Introductions
    Replies: 2
    Last Post: 11-01-2006, 01:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •