Results 1 to 4 of 4

Weird pop noise

This is a discussion on Weird pop noise within the Automatic Transmission forums, part of the Drivetrain category; Just put on some HID lights on n finally replaced my bulbs for the fog lights. Well as I was ...

  1. #1
    Junior Member TJKIDD's Avatar
    Join Date
    Mar 2011
    Location
    San Antonio,tx
    Posts
    26

    Black
    1999 camaro z28

    Weird pop noise

    Just put on some HID lights on n finally replaced my bulbs for the fog lights. Well as I was driving home i hear a loud pop and my car randomly jerked n stalled (its an a4) it felt as if my tranny just fell apart. Well luckily it still drove me home. When I got home I tried shifting it in reverse but it wouldn't shift it just roll n it just made a grinding noise. I just wanna know if any of y'all had this happen to you? Also when I was driving home it wounding shift up.

  2. #2
    Junior Member
    Join Date
    Apr 2007
    Location
    denton,Texas
    Posts
    27

    Hello

    Sounds like to me you broke your reverse sun shell. When it brakes you loose reverse,2nd,and fourth. Hope this helps Dave

  3. #3
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    I agree. Broken sunshell

  4. #4
    Junior Member TJKIDD's Avatar
    Join Date
    Mar 2011
    Location
    San Antonio,tx
    Posts
    26

    Black
    1999 camaro z28

    Thanx, yeah the guy i took it to told me the same thing, well he just rebuilt it and i'm getting my car back today

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Weird Noise on take off
    By 01SsRacing in forum General Help
    Replies: 6
    Last Post: 09-19-2012, 01:44 PM
  2. weird f***ing noise
    By maroca in forum General Help
    Replies: 3
    Last Post: 07-23-2009, 07:54 AM
  3. weird m6 noise
    By slimm4357 in forum Manual Transmission
    Replies: 1
    Last Post: 06-18-2008, 11:39 AM
  4. weird noise on ws6
    By tator98TA in forum Firebird / WS6
    Replies: 10
    Last Post: 01-31-2008, 05:00 PM
  5. Weird Noise?
    By vinnie311 in forum Firebird / WS6
    Replies: 6
    Last Post: 11-13-2006, 06:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •