Results 1 to 8 of 8

Trans problem????

This is a discussion on Trans problem???? within the Automatic Transmission forums, part of the Drivetrain category; I dunno if ne one has had this happen to them before, but anyways.... My camaro is an A4 and ...

  1. #1
    Junior Member yanoZ28's Avatar
    Join Date
    Oct 2009
    Location
    Killeen Tx.
    Age
    28
    Posts
    88

    Red
    2001 Z28

    Trans problem????

    I dunno if ne one has had this happen to them before, but anyways....
    My camaro is an A4 and lately, if ive gone WOT in OD, the trans wont downshift sometimes, but instead just "accelerate" in the current gear. especially around 30-35mph. It obviously (or at least to me) doesnt do this in just regural "D" but just OD.
    I checked all fluids, ran some trans honey through it... just have no idea why. The damn this just doest it when it feels like it. NE ideas or help???

  2. #2
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    more than likley it is nothing in the trans but input sensors on the motor that are getting old and not showing the computer the varibles it want to see in order tell the trans to down shift. It could be weak pressure but it is more than likley a sensor.
    The 4l60e shifts based on throtle possition sensor, manifold absolute pressure sensor, Mass air flow sensor, engine rpm, speed sensor and I'm sure there are a few more I missed.

  3. #3
    Junior Member yanoZ28's Avatar
    Join Date
    Oct 2009
    Location
    Killeen Tx.
    Age
    28
    Posts
    88

    Red
    2001 Z28

    Yeah Im wondering if this could be collateral damage from bending a pushrod and valve. Took care of that bout 500 miles ago
    '01 Z28 A4 : SLP lid, smooth bellow, K&N, UMI strut brace... Under Construction, Much more to come
    Best ET: 13.02

  4. #4
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    nah, just life of hard shifts.

  5. #5
    Junior Member yanoZ28's Avatar
    Join Date
    Oct 2009
    Location
    Killeen Tx.
    Age
    28
    Posts
    88

    Red
    2001 Z28

    Ill be damned, pulled out the MAF, and the screen was damaged and some nest-looking thing was wedged in there....odd, maybe my prob. No worries though, i was thinkin of a new 85mm slp one ne wayz. Now im just gotta pull out the old trusty haynes manual and start sensor hunting.
    thnx for the help

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by yanoZ28 View Post
    Ill be damned, pulled out the MAF, and the screen was damaged and some nest-looking thing was wedged in there....odd, maybe my prob. No worries though, i was thinkin of a new 85mm slp one ne wayz. Now im just gotta pull out the old trusty haynes manual and start sensor hunting.
    thnx for the help

    Best bet -- leave the MAF alone. If yours is damaged such that the screen can not be re-installed, get a stock GM replacement. Aftermarket MAFs do your car no favors and actually lean out the A/F. You can go up to about 500 hp with the stocker before it becomes a restriction.

    Interestingly, if you purchase a MAF from GM Parts Direct, they now send an 85 mm unit with an adapter harness. I replaced ours as the stock MAF had been de-screened, de-bladed and hacked up. The car had an off idle stumble that disappeared once the MAF was replaced: Mystery MAF?

  7. #7
    Junior Member yanoZ28's Avatar
    Join Date
    Oct 2009
    Location
    Killeen Tx.
    Age
    28
    Posts
    88

    Red
    2001 Z28

    Quote Originally Posted by pajeff02 View Post
    Best bet -- leave the MAF alone. If yours is damaged such that the screen can not be re-installed, get a stock GM replacement. Aftermarket MAFs do your car no favors and actually lean out the A/F. You can go up to about 500 hp with the stocker before it becomes a restriction.

    Interestingly, if you purchase a MAF from GM Parts Direct, they now send an 85 mm unit with an adapter harness. I replaced ours as the stock MAF had been de-screened, de-bladed and hacked up. The car had an off idle stumble that disappeared once the MAF was replaced: Mystery MAF?
    Interesting, hows the flow on the new GM MAF?

  8. #8
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by yanoZ28 View Post
    Interesting, hows the flow on the new GM MAF?

    I have no way to measure the flow difference -- stock is 78mm and the replacement is 85mm (if I measured correctly). At the time I ordered, I verified the P/N through GM Parts Direct. I did this again after I opened the box and found something quite different than I was expecting.

    From data logging the car, I am not seeing any timing pulled except under WOT. I attribute this to the crap that we call gas in my area. No other evidence of a lean condition and the engine revs smoothly without any hesitation.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Trans Problem!!!
    By 02 Camaro SS SLP in forum Manual Transmission
    Replies: 15
    Last Post: 09-22-2011, 07:42 PM
  2. Help: TRANS problem
    By JaycenK in forum Automatic Transmission
    Replies: 8
    Last Post: 01-13-2009, 12:45 PM
  3. trans problem maybe?
    By LetemSpin1 in forum Automatic Transmission
    Replies: 10
    Last Post: 04-15-2008, 03:34 PM
  4. 98 Trans Am A/C problem / its hot - help!
    By frank450r in forum Firebird / WS6
    Replies: 8
    Last Post: 08-11-2007, 11:00 AM
  5. Trans Problem Please Help!!!!!
    By jang89 in forum Automatic Transmission
    Replies: 6
    Last Post: 10-20-2006, 04:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •