Results 1 to 7 of 7

tranny issue think it might be planetary issue

This is a discussion on tranny issue think it might be planetary issue within the Automatic Transmission forums, part of the Drivetrain category; just got my first camaro off my bro that has a 05 gto twin turbo bout 5 months ago it ...

  1. #1
    Junior Member
    Join Date
    Feb 2009
    Location
    philly
    Posts
    29

    white
    1998 z28

    Question tranny issue think it might be planetary issue

    just got my first camaro off my bro that has a 05 gto twin turbo bout 5 months ago it a 98 z28 with a crappy 4l60e....! first things first it has alot of miles but i know for a fact these motors last a long time an take a beating but i dont car bout rebuilding anything on it..... it's the love of my life so here's the problem first gear grinds and reverse everything else is fine just cant find any info on what it could be but seems cant find the right one....willing to rebuild it but wanna get an idea of what it is....if anyone that might have had a similar problem PLEASE HELP!

    Last edited by nerisls1; 02-11-2009 at 07:49 PM.

  2. #2
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    does it grind or slip? the reaction shell could be stripped where it splines to the sun gear. if it is slipping i bet your low and reverse clutches are smoked. what does the fluid smell like

  3. #3
    Junior Member
    Join Date
    Feb 2009
    Location
    philly
    Posts
    29

    white
    1998 z28

    smells litter burnt like light brown color gotta member i never changed it had the car only for five months and actually had the prob when i bought it off my bro....but it was a steal so i said hell with it ....no slipping even if you beat it but once an a while if you stop at a light like yesterday feels like it locks up ...i dont know but i wanna fix it or get a good idea of what the problem might be

  4. #4
    Member fieropope's Avatar
    Join Date
    Jan 2009
    Location
    union mo
    Posts
    183

    white
    01 formula

    sounds like the rear sun gear needle bearing took a crap. all the scrapnel from the bearing goes into the rear planet and starts chewing that up and the more you drive it like that the more it eats. we see it all the time at our shop . you can useually have one of those rebuilt without problems and that year should be fairly cheap (under 1500)

  5. #5
    Member performabuilt's Avatar
    Join Date
    Jul 2006
    Location
    SUGAR LOAF PA
    Posts
    489

    blue
    2000ss

    Quote Originally Posted by nerisls1 View Post
    just got my first camaro off my bro that has a 05 gto twin turbo bout 5 months ago it a 98 z28 with a crappy 4l60e....! first things first it has alot of miles but i know for a fact these motors last a long time an take a beating but i dont car bout rebuilding anything on it..... it's the love of my life so here's the problem first gear grinds and reverse everything else is fine just cant find any info on what it could be but seems cant find the right one....willing to rebuild it but wanna get an idea of what it is....if anyone that might have had a similar problem PLEASE HELP!



    It does sound like you need a rebuild or a trans. Not sure I would say crappy 4l60e though there are guys running them in 9 and 10 second cars. Now if you mean the stock built 4l60e with anything over stock power then yes. But then it wasnt designed for that.
    FREE COOLER/SHIPING, NO CORE OR CHARGE,2YR WARRANTY, CUST TRACK VIDEOS click banner 4 website, CALL or text 570-578-5686 7 days a week 9 am till 10 pm.

  6. #6
    Junior Member
    Join Date
    Feb 2009
    Location
    philly
    Posts
    29

    white
    1998 z28

    i had it sitting in my garage for a while and i figured ill take it out for a quick spin to see if was still making noise cause out of no where sometimes it wouldnt make noise at all but it took a dump on me like 5 miutes of driving so only have 1st nothing else tell me about bad this sucks but im just putting it out there if anybody has a t56 swap i would really like to make it stick more fun for me haha

  7. #7
    Member
    Join Date
    Jul 2006
    Location
    Glen Carbon, IL
    Age
    39
    Posts
    397

    Silver
    2000 Camaro SS

    The stick may be more fun to drive, but from my experience they are more brittle than the 4L60E. I run mid 10's, so I wouldn't necessarily call a 4L60e crappy if built properly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle issue.. may be tune issue.. help?
    By okiels1 in forum General Help
    Replies: 2
    Last Post: 12-07-2016, 03:17 PM
  2. pvc issue... vacuum leak....tune issue?
    By okiels1 in forum General Help
    Replies: 3
    Last Post: 03-05-2016, 10:10 AM
  3. Help: Possible tranny issue with 95 dodge ram?
    By SteveCZ28 in forum Drivetrain
    Replies: 3
    Last Post: 08-24-2011, 10:32 AM
  4. Possible Tranny issue
    By Spikito in forum Drivetrain
    Replies: 6
    Last Post: 10-30-2008, 07:13 PM
  5. tranny issue
    By bmred99ws6 in forum Automatic Transmission
    Replies: 4
    Last Post: 06-28-2008, 08:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •