Results 1 to 6 of 6

Seat of the pants power is BACK!!

This is a discussion on Seat of the pants power is BACK!! within the Automatic Transmission forums, part of the Drivetrain category; I'm back on the road ..... after swapping out tranny and converter. I had to nail it yesterday on the ...

  1. #1
    Member 79Firebird_99TA's Avatar
    Join Date
    Apr 2007
    Location
    ATL
    Posts
    242

    Black
    99 Trans Am

    Seat of the pants power is BACK!!

    I'm back on the road ..... after swapping out tranny and converter. I had to nail it yesterday on the highway and the rear squatted - and the power is there again. I've got 150 miles on it. How long should I take it easy during break in? 200 miles?

  2. #2
    Senior Member
    Join Date
    Apr 2007
    Location
    Newport, RI
    Posts
    1,550

    Navy Blue Metallic
    '00 Formy A4

    Good to hear!!

    Maybe I missed it in your other thread, but what converter are you running now?

  3. #3
    Member 79Firebird_99TA's Avatar
    Join Date
    Apr 2007
    Location
    ATL
    Posts
    242

    Black
    99 Trans Am

    Quote Originally Posted by StuntmanMike View Post
    Good to hear!!

    Maybe I missed it in your other thread, but what converter are you running now?
    I've got a Vigilante 2500 with RPM level 4 tranny.

  4. #4
    Member 79Firebird_99TA's Avatar
    Join Date
    Apr 2007
    Location
    ATL
    Posts
    242

    Black
    99 Trans Am

    .... to add to this ... the whole thing has been a nightmare beginning last November. For your enjoyment:

    * november: transmission starts slipping

    * purchase 4l60e from transmission shop in MD. Also purchase 3200 stall converter from company in Houston with intention of installing everything myself.

    * 2011 - have no time to install so I have friend's shop install everything. Recieved the car with horrible vibration in neutral/park. Tranny company says converter, converter company says it's the installation. New TC get's shipped in and installed. Vibration gone in neutral but power is gone and there is a vibration when accelerating hard. Also tabs on the harness connector broken off so I had to repair that as the fluid was leaking bad. I installed an external cooler and had the computer tuned by Frost.

    * May - transmission burned up. Clutches shot. Fluid burnt to a crisp.

    * June - RPM tranny installed with Vigilante converter. I told the shop to throw everything else away.

  5. #5
    Senior Member Z28_Driver's Avatar
    Join Date
    Jun 2009
    Location
    Ohio
    Posts
    1,017

    Sunset Orange Metallic
    2002 Z28 Hardtop

    Wow that was a mess. Glad to hear its working out for you now.

  6. #6
    Member jsmith564`'s Avatar
    Join Date
    Apr 2009
    Location
    covington ga
    Age
    32
    Posts
    481

    yellow
    2004 gto

    thats bull chit. i'm glad you're up and running. but damn...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The back seat
    By Pete Rock98 in forum General Help
    Replies: 31
    Last Post: 03-16-2015, 06:16 PM
  2. What happened to the seat of the pants power?
    By 79Firebird_99TA in forum Automatic Transmission
    Replies: 23
    Last Post: 05-12-2011, 11:29 PM
  3. Back seat...
    By Huskerz1 in forum Convertible
    Replies: 8
    Last Post: 06-20-2006, 12:35 PM
  4. Replies: 4
    Last Post: 12-12-2005, 04:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •