Results 1 to 4 of 4

Problem with Lumina VY SS Auto

This is a discussion on Problem with Lumina VY SS Auto within the Automatic Transmission forums, part of the Drivetrain category; Loosing faith in the transmission of my Lumina, never knew the auto transmission was made out of chocolate. All that ...

  1. #1
    Junior Member
    Join Date
    Nov 2010
    Location
    Saudi Arabia
    Posts
    10

    Red
    Lumina SS

    Problem with Lumina VY SS Auto

    Loosing faith in the transmission of my Lumina, never knew the auto transmission was made out of chocolate. All that torque from the engine clearly wasn't catered for with the transmission. I bought the car with a recon tranny just fitted. Next thing I knew I had no 3rd or 4th gears, so took back to the original garage. They replaced a pump and solenoids, drove fine for a week and then same thing happened. Back to the garage and they changed a solenoid again and the clutch plates. 1 week later and the clutches are slipping at high revs and the engine just revs at 120km for no reason up and down. The garage rang me a week later telling me the car had an electrical fault and the gearbox would fail again if not sorted out. Great! tell me a week after driving it out of the garage. Funny how the warranty had just run out. So took the car to s different garage and they confirmed an electrical fault and the transmission is knackered. Needs new pump, solenoids and clutch plates again!!! My question is, how can an electrical fault kill a transmission so quickly and how long does a box normally last? Seriously thinking of converting to manual.

  2. #2
    dbl clutch'n like i shld WICKEDLS1's Avatar
    Join Date
    Aug 2010
    Location
    Oklahoma City, Oklahoma
    Posts
    1,807

    sebring silver
    Y2K SS CAMARO

    Quote Originally Posted by F1carbon View Post
    Loosing faith in the transmission of my Lumina, never knew the auto transmission was made out of chocolate. All that torque from the engine clearly wasn't catered for with the transmission. I bought the car with a recon tranny just fitted. Next thing I knew I had no 3rd or 4th gears, so took back to the original garage. They replaced a pump and solenoids, drove fine for a week and then same thing happened. Back to the garage and they changed a solenoid again and the clutch plates. 1 week later and the clutches are slipping at high revs and the engine just revs at 120km for no reason up and down. The garage rang me a week later telling me the car had an electrical fault and the gearbox would fail again if not sorted out. Great! tell me a week after driving it out of the garage. Funny how the warranty had just run out. So took the car to s different garage and they confirmed an electrical fault and the transmission is knackered. Needs new pump, solenoids and clutch plates again!!! My question is, how can an electrical fault kill a transmission so quickly and how long does a box normally last? Seriously thinking of converting to manual.

    sounds to me like someone is blowing smoke up your ass but thats just my .02

  3. #3
    Junior Member
    Join Date
    Nov 2010
    Location
    Saudi Arabia
    Posts
    10

    Red
    Lumina SS

    Thinking that myself but in Saudi Arabia there really is very little support for customers. The car is in Tristar Auto transmission specialist at the moment so hopefully they will get it sorted and I get plenty of life out of it.

  4. #4
    dbl clutch'n like i shld WICKEDLS1's Avatar
    Join Date
    Aug 2010
    Location
    Oklahoma City, Oklahoma
    Posts
    1,807

    sebring silver
    Y2K SS CAMARO

    Quote Originally Posted by F1carbon View Post
    Thinking that myself but in Saudi Arabia there really is very little support for customers. The car is in Tristar Auto transmission specialist at the moment so hopefully they will get it sorted and I get plenty of life out of it.
    yeah i would have taken it else where after the second mishap but if it was still under their warranty then it was ok i guess but hopefully these guys will get it done the correct way

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Auto tans problem.
    By Sarge91 in forum Drivetrain
    Replies: 14
    Last Post: 11-26-2008, 10:35 PM
  2. auto shifting problem
    By craZ28y dave in forum Drag Racing
    Replies: 5
    Last Post: 03-05-2007, 02:47 AM
  3. 94 z28 auto-transmission problem
    By tds1213 in forum Automatic Transmission
    Replies: 2
    Last Post: 07-19-2006, 11:05 AM
  4. shifter problem with auto
    By got-a-ls1 in forum General Help
    Replies: 6
    Last Post: 04-09-2006, 05:08 PM
  5. Auto Tranny Problem
    By iceman504 in forum Automatic Transmission
    Replies: 5
    Last Post: 03-01-2006, 03:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •