Results 1 to 5 of 5

p1810 Trans Pressure Switch code after shift kit install?

This is a discussion on p1810 Trans Pressure Switch code after shift kit install? within the Automatic Transmission forums, part of the Drivetrain category; Howdy everyone, im brand new to this forum and i need some help. I just had a shift kit installed ...

  1. #1
    Junior Member ari1843's Avatar
    Join Date
    Jun 2015
    Location
    Austin, TX
    Posts
    3

    Silver
    2000 Camaro Z28

    p1810 Trans Pressure Switch code after shift kit install?

    Howdy everyone, im brand new to this forum and i need some help. I just had a shift kit installed on my 2000 z28. The car has 107,000 miles and is relatively stock. There were no issues before the shift kit, i just wanted to add a little spark to it. After the shift kit was installed it drove great shifted just fine. I parked it, cranked it back up when I was leaving work and the check engine pops on. (P1810 Trans Pressure Switch) i called the tranny guy and says to change out the switch. So I changed the switch (brand new AC Delco) and inspected the wiring harness. went out for a drive and it was totally fine. Once again as I was leaving work the check engine pops on again, while I am in park and the car idling. Thing is the car drives great and shifts great. No issues what so ever besides the check engine light. Has anyone else run into this issue? If anyone has an idea please let me know!

    Thanks lots!!

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Welcome to the site! Modified transmissions make more line pressure. Could be as simple as the increased pressure is popping a code... or something went amiss during the install. I am away for the weekend, but can pull the info on the code to determine what conditions will set it.

  3. #3
    Junior Member ari1843's Avatar
    Join Date
    Jun 2015
    Location
    Austin, TX
    Posts
    3

    Silver
    2000 Camaro Z28

    Thanks! And that's what i was thinking about the increased pressure, i mentioned it to the trans builder and he said the shift kit alone wouldn't throw any code..but i think it might have something to do with it. If that's the case, do i just need to have the computer tuned? The car drives pretty much the same as it did before the shift kit, only now i have this check engine light. im also thinking its likely something could have gone wrong. Says hes done these shift kits on 4l60e's and never had any issues. i might just have to find another trans builder to check it out. but i really appreciate it! and if you could get the info that would be great! thanks!

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    The only reason I thought of that was that I installed a Performabuilt Level II in our car, but forgot to have the tune adjusted first. This resulted in stupid high line pressures as both the valve body and tune were amplifying pressures. Once the pressures were set back to stock in the tune everything settled down and worked great.

  5. #5
    Junior Member ari1843's Avatar
    Join Date
    Jun 2015
    Location
    Austin, TX
    Posts
    3

    Silver
    2000 Camaro Z28

    p1810 Trans Pressure Switch code after shift kit install?

    Gotcha. We used the transgo sk kit. Only replaced/added a few of the springs, replaced the plastic accumulator piston and spring with two aluminum pistons. None of the holes in the separator plate were drilled larger than .092...didn't mess with the servo or anything else. The pan/fluid was also very clean when we pulled it out

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. p1810 trouble code! TFP sensor circuit! IM STUMPED!!!!! :(((
    By LSSurprise in forum Automatic Transmission
    Replies: 2
    Last Post: 02-15-2014, 11:16 AM
  2. Help: p1810 trouble code! TFP sensor circuit! IM STUMPED!!!!! :(
    By LSSurprise in forum General Help
    Replies: 1
    Last Post: 02-14-2014, 04:40 AM
  3. 2 Shift solenoid ECM code After stall converter install
    By wcboricua in forum Automatic Transmission
    Replies: 6
    Last Post: 01-05-2011, 07:44 PM
  4. Replies: 6
    Last Post: 01-12-2007, 07:14 AM
  5. oil pressure switch.
    By hottss350 in forum External Engine
    Replies: 3
    Last Post: 09-13-2006, 09:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •