Results 1 to 4 of 4

Leaky 4l60E

This is a discussion on Leaky 4l60E within the Automatic Transmission forums, part of the Drivetrain category; What luck .... just when I thought all was good with the TA, she starts shifting soft. Check transmission fluid ...

  1. #1
    Member 79Firebird_99TA's Avatar
    Join Date
    Apr 2007
    Location
    ATL
    Posts
    242

    Black
    99 Trans Am

    Leaky 4l60E

    What luck .... just when I thought all was good with the TA, she starts shifting soft. Check transmission fluid and see a 6' x 3' leak under car. It's leaking from the electrical connector on the R side. What kind of seal is that and do I have to pull the valve body to get to it? Back in the 32 year old car for my daily driver.

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,997

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Its an oring and I nearly positive it can be access with the valve body in place. You'd just have to remove the trans pan to remove and replace the oring.

  3. #3
    Member 79Firebird_99TA's Avatar
    Join Date
    Apr 2007
    Location
    ATL
    Posts
    242

    Black
    99 Trans Am

    Yeah ... you're right. I did some more research and the odds are, the connector tab(s) got broken somehow the last time it was pulled out. It was pulled 2 times. After the first time - there was no leak. After the 2nd time - there was...hmmmm.

    I will check it out tomorrow. If I have to I'll get this: http://www.sonnax.com/product-lines/...ion/parts/1573

    Darn it .... I just want to drive my TA.

  4. #4
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,997

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Here's a picture of what it looks like. Looks like you'll have to remove that solenoid to remove it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: leaky t tops
    By Ieatstangs in forum General Help
    Replies: 3
    Last Post: 02-13-2012, 08:04 AM
  2. Leaky intake
    By WS6_Birdman02 in forum Firebird / WS6
    Replies: 8
    Last Post: 04-09-2010, 01:05 PM
  3. Leaky Band clamps...
    By RedRocketZ28 in forum External Engine
    Replies: 8
    Last Post: 11-08-2007, 01:01 AM
  4. leaky t-tops
    By 02TransSD in forum Firebird / WS6
    Replies: 8
    Last Post: 08-02-2007, 05:31 PM
  5. leaky slave i guess
    By gsrrob in forum Manual Transmission
    Replies: 0
    Last Post: 03-23-2007, 01:32 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •