Results 1 to 11 of 11

Icky shifting

This is a discussion on Icky shifting within the Automatic Transmission forums, part of the Drivetrain category; Do all these trannys shift like crap or is there something wrong with mine. First to second feels like it ...

  1. #1
    Junior Member
    Join Date
    Sep 2009
    Location
    illinois
    Posts
    94

    Black
    2000 Trans Am

    Icky shifting

    Do all these trannys shift like crap or is there something wrong with mine. First to second feels like it has a 2 second delay even at wot and all the other shifts feel like i'm in a grand marquis. Will a shift kit fix this prob. 00 ta 109k mi

  2. #2
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Have you changed fluid lately?

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Our car shifts quite nicely -- changed the shift firmness up a notch with a handheld, plus recently changed the filter and fluid. The only delay we have is when the car is shifted manually from second to drive. That problem is discussed in this thread: Frost...tranny settings

  4. #4
    Junior Member
    Join Date
    Sep 2009
    Location
    illinois
    Posts
    94

    Black
    2000 Trans Am

    Have not changed fluid yet, only owned car for a couple of months

  5. #5
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Start with fluid and filter. No telling how long the previous owner went before changing it, if they ever even changed it at all...

  6. #6
    Member 346ci's Avatar
    Join Date
    Sep 2007
    Location
    AK
    Age
    27
    Posts
    553

    NBM
    1998 Z-28

    Shift kit and a tune will help a lot as well. When you go to change the fluid smell it, if it has burnt smell you better prep for a rebuild.

  7. #7
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by croslod View Post
    Do all these trannys shift like crap or is there something wrong with mine. First to second feels like it has a 2 second delay even at wot and all the other shifts feel like i'm in a grand marquis. Will a shift kit fix this prob. 00 ta 109k mi
    If you did'nt have the high miles I'd say it's normal/common. I had the shift firmness changed a while back mine does it too (feels like it slips a little then pulls). I can assure you mine is'nt bad(extremely well taken care of). However, high mileage can definetly cause issues. I'd have it flushed with a fluid change first, then go from there..
    Last edited by Smittro; 10-28-2009 at 11:32 PM.
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  8. #8
    Junior Member
    Join Date
    Sep 2009
    Location
    illinois
    Posts
    94

    Black
    2000 Trans Am

    Thanks! The fluid doesn't smell burnt,i'll change the fluid sometime in the near future. Anyone have any suggestions for the fluid,DEXIII or what? How many qts wil it hold just draining the fluid?

  9. #9
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by croslod View Post
    Thanks! The fluid doesn't smell burnt,i'll change the fluid sometime in the near future. Anyone have any suggestions for the fluid,DEXIII or what? How many qts wil it hold just draining the fluid?
    Make sure to change the filter too. I did ours around 6 months ago but cannot remember how much fluid it took.

  10. #10
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Thought it was somewhere in the ballpark of 5 qts if just pulling the pan and 14 qts if completely dry.

  11. #11
    Member
    Join Date
    Oct 2009
    Location
    NorCal
    Posts
    260
    02 Z28

    Quote Originally Posted by pajeff02 View Post
    Our car shifts quite nicely -- changed the shift firmness up a notch with a handheld, plus recently changed the filter and fluid. The only delay we have is when the car is shifted manually from second to drive. That problem is discussed in this thread: Frost...tranny settings
    oh man. you have no idea how happy i am that it wasnt just my car doin that.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. not shifting
    By 346ci in forum Automatic Transmission
    Replies: 16
    Last Post: 05-29-2014, 03:17 PM
  2. 05 and 06 shifting
    By 06goat60 in forum GTO
    Replies: 7
    Last Post: 09-07-2008, 05:01 PM
  3. Shifting
    By 01ws6er in forum Drag Racing
    Replies: 21
    Last Post: 03-19-2008, 07:31 AM
  4. what am I shifting at?
    By william SS in forum Automatic Transmission
    Replies: 5
    Last Post: 11-15-2007, 09:45 AM
  5. A4 not shifting
    By mysticZ in forum Automatic Transmission
    Replies: 12
    Last Post: 08-31-2006, 06:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •