Results 1 to 6 of 6

Help!!! Whats wrong with my transmission

This is a discussion on Help!!! Whats wrong with my transmission within the Automatic Transmission forums, part of the Drivetrain category; my car revs like theres no transmission fluid but there is plenty of fluid in the car. when your on ...

  1. #1
    Junior Member
    Join Date
    Mar 2011
    Location
    iowa!!!
    Posts
    3

    Black
    1995 trans am

    Help!!! Whats wrong with my transmission

    my car revs like theres no transmission fluid but there is plenty of fluid in the car. when your on the gas sometimes it will be driving fine but when you let off the gas it bogs down like if you were in low and let off the gas. the guy who just fixed my head-gasket noticed that the fans in my weren't turning on soon enough so my car gets hot....so he said i might need to get the computer checked out didn't know if getting a new computer would fix the transmission not shifting right. ANY INFORMATION WOULD HELP GREATLY!! THANKS!

  2. #2
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    So is the car not shifting then?

    Please provide more info.

  3. #3
    Junior Member
    Join Date
    Mar 2011
    Location
    iowa!!!
    Posts
    3

    Black
    1995 trans am

    it shifts but it will sometimes but at lower speeds when i give it gas it will rev and to like 4000 rpm like its not in gear but then ill let off the gas and drop it in to something lower than drive it will start to move

  4. #4
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    My pump went out and burned up the clutches, sounds like a similar problem...does 1st and 2nd gear work when you manually shift?

    Mine did...

  5. #5
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    1st thing I'd do is a new filter and fluid...it doesn't take much to clog up all those small holes in the pump and valvebody

  6. #6
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    Trans is slipping like stated above. you can try the fluid and filter but more than likley it's time to have a trans guy look at it and see if it is rebuild time or something else as for your cooling problems...Thats a stock LT1 tune for ya. Fans in these things don't turn on untill 220 or something? Anyway you can get a tune to fix that or there are several ways you can wire them up to run a manual fan switch but if you use your A/C I would have a tune done. easiest way to do it for a 95 is to do this if you have a laptop or willing to take your computer out to your car. Buy a interface cable from a place like this. http://www.moates.net/aldu1-and-cabl....html?cPath=64 there maybe a sponser that sells them and if so Moderator can you replace the link or post there name please. Then you can oder a tune from some one like this that offers a e-mail tune like this http://www.madtuner.com/index.php?pa...mart&Itemid=26. Ion will give you the software a link to the free trail software and data logger that you need to tune it. I used him for my custom 383 and he nailed it on the head. Again there may be a site sponser that can do this so the Moderator may deleat my links if there is.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can someone tell me whats wrong with this LS2
    By LS2SS in forum General Help
    Replies: 8
    Last Post: 10-16-2013, 07:41 PM
  2. Umm... I don't know whats wrong??
    By WS6Dream in forum General Help
    Replies: 1
    Last Post: 03-30-2011, 05:33 PM
  3. Help: Whats wrong?
    By TruThug in forum Firebird / WS6
    Replies: 20
    Last Post: 01-27-2011, 07:01 PM
  4. Question: Whats wrong with my T/A?
    By Dann in forum Firebird / WS6
    Replies: 8
    Last Post: 06-03-2009, 08:45 AM
  5. whats wrong
    By huggerls1 in forum General Help
    Replies: 5
    Last Post: 01-10-2009, 09:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •