Results 1 to 5 of 5

It clicks...?

This is a discussion on It clicks...? within the Automatic Transmission forums, part of the Drivetrain category; There is a loud clicking sound comng from the front of the trans,I believe its the converter, but i dont ...

  1. #1
    T/A is in Bahrain! 13nickels's Avatar
    Join Date
    Mar 2008
    Location
    Manama, Bahrain
    Age
    38
    Posts
    139

    Red
    1998 Trans Am WS7

    It clicks...?

    There is a loud clicking sound comng from the front of the trans,I believe its the converter, but i dont know. I sometimes clicks when its not in drive. but as soon as I put it in drive it clicks and matches my rpm through gears. Sometime it doesnt make any noise. Any suggestions on how to check it.

  2. #2
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    Make sure the converter bolts havent backed out and loosened the converter. I have had converter bolt come flying out from under the car before. Mostley after I had someone do trans work but I use lock tight on them now.

  3. #3
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by JaycenK View Post
    Make sure the converter bolts havent backed out and loosened the converter. I have had converter bolt come flying out from under the car before. Mostley after I had someone do trans work but I use lock tight on them now.
    On the dot.

    Its most likely this or something internal.

  4. #4
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    could be the converter

  5. #5
    Exalted Cyclops 67CamaroRSSS's Avatar
    Join Date
    Feb 2007
    Location
    San Diego, CA
    Posts
    5,824

    2002 Z28 A4 NBM
    Sadly now demodded :(

    Flexplate broken maybe?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: car clicks and wont start up
    By dethinboots in forum GTO
    Replies: 2
    Last Post: 06-02-2012, 04:49 AM
  2. Help: strange clicks and cluth issue?
    By TerribleTed in forum General Help
    Replies: 4
    Last Post: 02-08-2011, 05:15 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •