Results 1 to 2 of 2

broke the bottom part of transmission

This is a discussion on broke the bottom part of transmission within the Automatic Transmission forums, part of the Drivetrain category; I was in a parking lot with my friend, he had a car too. there were two parking lots adjacents ...

  1. #1
    Junior Member nevaziah's Avatar
    Join Date
    Aug 2006
    Location
    ottawa
    Age
    32
    Posts
    4

    Red
    2001 Sunfire

    broke the bottom part of transmission

    I was in a parking lot with my friend, he had a car too. there were two parking lots adjacents to eachother. He starts his car, goes foward to the next parking lot. I run my car and decide to do the same thing, but i front of "me" there was a small cement square, left over from one of those parking bumps that I hadnt noticed.

    To make a long story short, there was a lot of bumping and grinding under my car. My little sunfire 2001's transmission is apparently broken under the motor, oil leaked out and the plate is a bit peeled off. I got an estimate to replace the plate for 260$ CAD from Canadian tire, but the problem is the tech there says something is proken inside.

    Say worst comes to worst, how much would it cost to replace the transmission "block" that's right under the motor? and any canadians in ottawa, please suggest a few shops i can go to....

  2. #2
    Junior Member nevaziah's Avatar
    Join Date
    Aug 2006
    Location
    ottawa
    Age
    32
    Posts
    4

    Red
    2001 Sunfire

    Update!

    Question 1:
    Well, I replaced the Transmission pan, the filter and the gasket and added new transmission oil. THe car is running fine now exept it seems to strain a bit more in first and second gear and the engine temperature is going over 90, which never happened before. should i have waited until the transmission fluid had settled into the new filter or is it okay to drive it right then?

    Question 2:
    I checked oil levels, they were very low, at the filll point. I added about 0.8 L of oil (5w-30) and the oil seems a bit too high right after I added it. Should I wait for it to settle down? if so, how long?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. part of my throttle cable bracket broke
    By 98TransAmWs-6 in forum General Help
    Replies: 4
    Last Post: 04-24-2011, 08:57 AM
  2. Help: Dirver's door guide roller broke part discontinued
    By gotabekidding in forum General Help
    Replies: 5
    Last Post: 07-17-2010, 02:51 PM
  3. Oops, It broke Transmission experts please come in
    By sunsetorangess in forum Automatic Transmission
    Replies: 2
    Last Post: 08-11-2009, 10:11 AM
  4. Need GM battery bottom part number
    By 99bluebird in forum General Help
    Replies: 31
    Last Post: 02-13-2009, 02:16 PM
  5. Transmission Broke?
    By ChrisH in forum Manual Transmission
    Replies: 7
    Last Post: 12-18-2006, 07:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •