Results 1 to 4 of 4

The Beast Broke?

This is a discussion on The Beast Broke? within the Automatic Transmission forums, part of the Drivetrain category; Ok so I have had lots of problems with a monster trans I bought back inNovember and it recently to ...

  1. #1
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    The Beast Broke?

    Ok so I have had lots of problems with a monster trans I bought back inNovember and it recently to a crap all together. Some of you help me diagnos it as a broken sunshell and congrates to your tech skills guys cuz you were right.
    I took the trans back to monster so they could open it up and find out what the problem was and as I said it was the sun shell but they did not belive me when I told them this and argued with me about it untill they opened the trans up.
    I get a call that I can come get my new trans and show up to find the master tech waiting for me and he is laughing. He first says I have never seen this before in my life and he pulls out the sunshell and it is in 2 peices. As I look at it I realize it is not a stock sun shell but The Beast it's self laying in his hands in 2 peices.
    It seems the shell broke not at the weak link but on the back side half way between the splines and the side of the shell in a perfect circle.

    Has anyone else broken the beast before? Mind you that I run no juice and have a stock LT1 with headers and a catback, lol thats it. This thing broke on a first to second shift on street tires with 3.23 gears.

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    yeah I've seen stock ones strip out the splines and I've seen stock ones break in two pieces as you described. Probablly just a fluke and won't happen to you again

  3. #3
    Member fieropope's Avatar
    Join Date
    Jan 2009
    Location
    union mo
    Posts
    183

    white
    01 formula

    sounds like manufacturer defect to me .ive seen one beast strip the splines but never fracture the shell .

  4. #4
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    well it is kind of fitting because if something is going to break or go wrong... it happens to me lol. Yea I hope that was the last time that happens.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My New Beast
    By WS6Dream in forum Firebird / WS6
    Replies: 67
    Last Post: 01-10-2011, 05:32 PM
  2. The beast!
    By TmaxicanA in forum Firebird / WS6
    Replies: 9
    Last Post: 06-09-2010, 02:20 PM
  3. The Red Beast
    By Bottlefedz28 in forum Member's Rides
    Replies: 4
    Last Post: 12-03-2009, 04:27 PM
  4. My Beast is Gone...
    By BlankinSShip in forum Camaro / SS
    Replies: 1
    Last Post: 07-21-2008, 10:53 AM
  5. My New Beast!!
    By wantaLS1 in forum Camaro / SS
    Replies: 17
    Last Post: 10-25-2007, 07:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •