Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Bad stall?

This is a discussion on Bad stall? within the Automatic Transmission forums, part of the Drivetrain category; I did up a heads/cam lt1 a while ago. Before the stall, it seemed to have a lot of power, ...

  1. #1
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    Bad stall?

    I did up a heads/cam lt1 a while ago. Before the stall, it seemed to have a lot of power, then the stall went in, turned into a dog and could barely spin the tires. Its a yank 3600. I know the knock sensors are being tripped to 5 degrees and they are going to be turned off when its getting tuned tonight because of false knock. anyone else ever had an issue like this?

  2. #2
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    is it just from a Stop or from a roll also?

  3. #3
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    Both

  4. #4
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    sounds more like a possible tune issue, But Im sure a stall could be bad. Get the car tuned, then if it still has no power go back to the stock converter to confirm its a converter problem.

  5. #5
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    Yeah, that so far is the plan, I hope it is in the tune because tearing out the trans sucks, especially doing it more than once.

  6. #6
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    Ya no kidding, Is it a New stall or used?

  7. #7
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    brand new from yank

  8. #8
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    Have you done any other transmission upgrades?

  9. #9
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    except the shift kit, no, and that was a long time ago.

  10. #10
    Awaiting Activation
    Join Date
    Aug 2007
    Location
    odessa,texas
    Posts
    1,056

    69 hugger orange
    98 z28

    possible that your clutches are starting to slip

  11. #11
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    Problem found. Somehow, when I put the dipstick tube back in, on top I must have bumped the #8 injector connector and it came off. Runs like a raped ape now, only prob is that he cracked the flex plate so I have pull the trans again, dang it anyways, but that car is so much fun to drive now, well, after the new flex plate.

  12. #12
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    Awesome!! I guess its hard to run on 7cyl LOL

  13. #13
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    Its funny, it took driving it like that for 250 miles to throw a code that the #8 injector was not reading.

  14. #14
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    Did the car not have a miss? looks like that would have been a dead clue.

  15. #15
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    It ran a little rough at idle, but no noticeable miss. Thats why I was stumped and blamed the stall.

  16. #16
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    HAHA, Well at least that was an easier fix. Too bad for the Flex plate tho!! It was a loose situation.

  17. #17
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    This car has become the bane of my existance. Get it fixed, works great, get to the dyno, one pull and the opti takes a dump. I hate lt1's.

  18. #18
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by 98formy View Post
    This car has become the bane of my existance. Get it fixed, works great, get to the dyno, one pull and the opti takes a dump. I hate lt1's.
    I'm completely confused by that. You have a 98 right? No LT-1 or opti. Did I miss something?

  19. #19
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    Quote Originally Posted by 0rion View Post
    I'm completely confused by that. You have a 98 right? No LT-1 or opti. Did I miss something?

    Its my brother in laws car. 95 camaro

  20. #20
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    Thumbs up

    Quote Originally Posted by 98formy View Post
    only prob is that he cracked the flex plate so I have pull the trans again, dang it anyways, but that car is so much fun to drive now, well, after the new flex plate.
    Do yourself a huge favor, and purchase a TCI SF29 flexplate, Jeg's and Summitt carry them, it will be the last flexplate your vehicle ever needs.

    SteveC

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. stall doesnt...stall
    By JacobLS1 in forum Automatic Transmission
    Replies: 18
    Last Post: 09-30-2012, 07:41 PM
  2. Question: A little Stall help? anyone?
    By Rikki_SeVeN in forum Automatic Transmission
    Replies: 5
    Last Post: 10-21-2009, 10:23 PM
  3. right stall for me
    By mr_r0bert0 in forum Automatic Transmission
    Replies: 9
    Last Post: 12-16-2008, 07:50 PM
  4. to stall or not to stall that is the question
    By Bandit1 in forum Drivetrain
    Replies: 21
    Last Post: 07-08-2008, 08:26 AM
  5. Replies: 15
    Last Post: 07-02-2007, 02:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •