Results 1 to 3 of 3

Automatic shift problems

This is a discussion on Automatic shift problems within the Automatic Transmission forums, part of the Drivetrain category; I have a 2001 Camaro Z28 ls1 auto trans earlier today it started not wanting to shift until it got ...

  1. #1
    Junior Member
    Join Date
    May 2015

    2001 camaro z28

    Automatic shift problems

    I have a 2001 Camaro Z28 ls1 auto trans earlier today it started not wanting to shift until it got to higher rpm's about 3000 - 3500 I know it does it in 1st and 2nd but never let it shift higher then that. Pulled over and shut the car off for a couple minutes restarted it and then it was fine shifted normal like it always has. Came home went back out later on and it did it again so I pulled over shut it off then restarted it and it was shifting fine again. Anyone know what the problem could be or where to start looking?

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Mansfield, PA

    Black & Blue
    '02 WS.6 / '07 Suburban

    Any codes being set?

    First thing you do with an auto trans is replace the fluid and filter when it has troubles. Inspect the old fluid to determine if it is black or has a burned smell to it. You could be having an issue with a solenoid, accumulator, or it could be as simple as the TPS sensor being out of adjustment. Shift points are determined by a combination of factors.

  3. #3
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Branchville, NJ

    Silver & Blue
    02 Camaro SS, 04 GTO

    A solenoid is my guess and they sometimes do not throw a code. If the trans has never been apart it may be that time. If you are good with a wrench you can do it yourself but if you are not sure, buddy up with a trans guy and maybe do it on a Sunday. Solenoid packs and clutch packs are two of the most common failures in a 15 year old transmission. Good luck.
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Automatic Shift boot and new shift handle
    By stew215 in forum Appearance Section
    Replies: 21
    Last Post: 04-21-2011, 02:04 PM
  2. shift kit for automatic
    By 99ta/cg in forum Automatic Transmission
    Replies: 21
    Last Post: 02-08-2011, 01:11 AM
  3. automatic wont shift...
    By 2000silverbullet in forum Automatic Transmission
    Replies: 4
    Last Post: 08-11-2008, 03:47 AM
  4. Automatic shift linkage
    By Chad97SS in forum LT1
    Replies: 2
    Last Post: 05-01-2008, 07:35 AM
  5. Automatic Shift Pattern
    By Rhinohuey in forum Almost Anything Goes
    Replies: 25
    Last Post: 07-11-2007, 01:22 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts