Results 1 to 8 of 8

98 Z28 auto trans prob..

This is a discussion on 98 Z28 auto trans prob.. within the Automatic Transmission forums, part of the Drivetrain category; Hello, Help...lol....Just bought a 98 Z-28 that had a trans rebuild a year and 3 months ago.. it is now ...

  1. #1
    Junior Member
    Join Date
    Apr 2006
    Location
    Arizona
    Age
    51
    Posts
    1

    White
    1998 Z-28

    Red face 98 Z28 auto trans prob..

    Hello, Help...lol....Just bought a 98 Z-28 that had a trans rebuild a year and 3 months ago.. it is now 3 months out of warranty(go-figure).. It engages just fine in reverse, low1, and low2..however when put in drive or overdrive from a stop, when it shifts on its own from low1 into low2, it pops into what acts like neutral... however if put into low1 or 2 from a stop, and shifted into drive or overdrive manually, then it performs fine... Does this sound familiar to anyone???

  2. #2
    Sideways to da next light redline's Avatar
    Join Date
    Jan 2006
    Location
    okc
    Age
    34
    Posts
    111

    black
    2000 trans am

    check fluid level and line pressure

  3. #3
    Junior Member
    Join Date
    Mar 2006
    Location
    Iowa
    Posts
    14

    White w/ red stripes
    87 MonteCarlo SS LS1/4L60

    that sounds similar to my issue but i havent gotten it to engage into drive/ or overdrive. What specifically do you mean line pressure?

  4. #4
    Sideways to da next light redline's Avatar
    Join Date
    Jan 2006
    Location
    okc
    Age
    34
    Posts
    111

    black
    2000 trans am

    by checking pressure you can determan if the pump has gone bad. A good pressure reading should be above 20psi. The only way i know to check pressure is to hook up a flush machine but maybe someone else can tune in and tell us an easyer way. as far as reverse and 1-2 manualy you will always have it since its a strait gear. In the mean time follow your tranny cooler lines from the radiator to the tranny and see if you can find any leaks or kinks in the lines. good luck!

  5. #5
    You lost the 3-4 clutch pack here. This is common, you need to increase the clutch count form 6 Borg Warner Hi-Energy's, to 8 or 9, and install the "modified" Trans-Go Performance Shift kit. There are other things that can be done, but this is a good start.

  6. #6
    Junior Member
    Join Date
    Jun 2006
    Location
    TORONTO
    Age
    37
    Posts
    7

    SILVER
    2000 Z28

    Auto trans

    Just bought a 2000 Z28. When I put into drive from park I get this like pinning sound like little pieces of metal hit eachother. Not really sure how to explain it but. I thought it something to do with my U-joints so I re[placed them. That didn't help. Any suggestions?

  7. #7
    Junior Member
    Join Date
    Feb 2006
    Location
    mt vernon tx
    Posts
    8

    black
    2000camaro

    the pinging your hearing is the same problem i have with my b4c. it is caused by a little slack the rear end gears which would be because of mileage or hard driving. mine has done it since i bought it and it has not gotton any worse since then but it still worries me as well but the car performs just fine. i would say as long as it does not get any worse, i would keep driving and just get ready to rebuild it as soon as possible. i myself am going over to 3.73's because i anticipate a 6-speed conversion in the near future but the choice of gears is up to you. have fun just keep check on that rear end.

  8. #8
    you have either a low or input sprag issue , manually shifting through the lower gears bypasses the low roller and the input roller clutch , you will have to have transmission removed and repaired or replace it ,
    megamax

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Pontiac Firebird Firehawk Trans Am, T-Tops, Auto Trans
    By Handyman401 in forum Vehicles For Sale / Trade
    Replies: 0
    Last Post: 11-20-2011, 06:33 PM
  2. Auto trans
    By Joels1 in forum Automatic Transmission
    Replies: 4
    Last Post: 03-24-2010, 07:30 AM
  3. For Sale: 98 Trans Am LS1/Auto
    By 1998ls-1TA in forum Vehicles For Sale / Trade
    Replies: 1
    Last Post: 11-05-2009, 07:45 PM
  4. 2000 Trans Am WS6 auto trans trouble
    By 10874477g in forum External Engine
    Replies: 2
    Last Post: 09-12-2008, 05:34 PM
  5. help with auto trans!!!
    By milleniumz in forum Automatic Transmission
    Replies: 6
    Last Post: 09-26-2007, 03:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •