Results 1 to 20 of 20

98 z28 A4 bounces of rev. limter at WOT WDF???

This is a discussion on 98 z28 A4 bounces of rev. limter at WOT WDF??? within the Automatic Transmission forums, part of the Drivetrain category; I got a 98 z28 A4 with 145k miles. It was one owner before me which the gentlemen was 68 ...

  1. #1
    The Red Reaper 98Z28importslayer's Avatar
    Join Date
    Feb 2008
    Location
    Spring hill, TN
    Posts
    210

    Red
    1998 Camaro Z28 T-Top A4

    98 z28 A4 bounces of rev. limter at WOT WDF???

    I got a 98 z28 A4 with 145k miles. It was one owner before me which the gentlemen was 68 years of age and never drove the car hard at all and maitenence was done ontime or before hand. I bought it completly stock. I just changed the trans. fluid about 2k miles ago. The shifts are fine and no problems at all at normal driving condtions but when i floor it, it will reach about 6000-6100rpms and bounce of the rev. limter for a few seconds so i have to let of the gas, let it shift then get back in it again. I was told i just need to get my line pressure increased and a tune ??? any advice is appreicaited

  2. #2
    The Red Reaper 98Z28importslayer's Avatar
    Join Date
    Feb 2008
    Location
    Spring hill, TN
    Posts
    210

    Red
    1998 Camaro Z28 T-Top A4

    any advice???

  3. #3
    Make real real sure Johns00Z28's Avatar
    Join Date
    May 2006
    Location
    Germantown, MD
    Age
    40
    Posts
    2,404

    Black
    2000 Z-28

    Sounds like it has an aftermarket stall.

  4. #4
    Quote Originally Posted by 98Z28importslayer View Post
    I got a 98 z28 A4 with 145k miles. It was one owner before me which the gentlemen was 68 years of age and never drove the car hard at all and maitenence was done ontime or before hand. I bought it completly stock. I just changed the trans. fluid about 2k miles ago. The shifts are fine and no problems at all at normal driving condtions but when i floor it, it will reach about 6000-6100rpms and bounce of the rev. limter for a few seconds so i have to let of the gas, let it shift then get back in it again. I was told i just need to get my line pressure increased and a tune ??? any advice is appreicaited
    Could be the tranny getting sloppy, get the rev limiter raised.

  5. #5
    The Red Reaper 98Z28importslayer's Avatar
    Join Date
    Feb 2008
    Location
    Spring hill, TN
    Posts
    210

    Red
    1998 Camaro Z28 T-Top A4

    Quote Originally Posted by Z28_06374 View Post
    Could be the tranny getting sloppy, get the rev limiter raised.
    Im having a friend tune me car with HP tuners so hes going to do everything for me. What do you think about raising the line pressure at WOT ?

  6. #6
    Quote Originally Posted by 98Z28importslayer View Post
    Im having a friend tune me car with HP tuners so hes going to do everything for me. What do you think about raising the line pressure at WOT ?
    Raise it up some but dont go crazy with it. Remove TQ management also. Set the shift points to 6000 with the limiter at 6300, I wouldnt go over that with stock valve springs. I have mine shifting at 6300 with the limiter at 6600 with ls6 springs.

  7. #7
    Just a souped up sunfire. Ryans99LS1's Avatar
    Join Date
    Jun 2007
    Location
    Parma Heights, Ohio
    Age
    27
    Posts
    891

    SOM
    99 Trans Am

    The bands inside might be getting worn out. A tune may make it go away for awhile but if you continue the spirited driving it will come back.

  8. #8
    The Red Reaper 98Z28importslayer's Avatar
    Join Date
    Feb 2008
    Location
    Spring hill, TN
    Posts
    210

    Red
    1998 Camaro Z28 T-Top A4

    So how would doing a trans. flush, raising the line pressure, taking TQ off and having the shift points adjusted along with the rev limiter and if its still having issues i should go buy another 460le, rebuild it with all the goodies and just wait tell the one thats in the crap out ?

  9. #9
    Just change the fluid, filter and throw on a good cooler in line after your stock radiator cooler and run it until it pops. I wouldnt be to concerned with it, mine was doing that also I just had the tune tweeked to keep it off the limiter. Its been fine since, and I beat the snots out of it. What are your mods?

  10. #10
    These trannys are real sensitive how much fluid is in or not in them. Its best to run them 1/2 quart over (check hot). Oh and dont run synthetic...

  11. #11
    The Red Reaper 98Z28importslayer's Avatar
    Join Date
    Feb 2008
    Location
    Spring hill, TN
    Posts
    210

    Red
    1998 Camaro Z28 T-Top A4

    Right now my mods are Lid, Ported and Polished TB, All the free mods, Raised airlid assembly, smooth bellows, dumped exhaust with no cats or mufflers, removed front bumper foam reinforcment to get more air into the engine bay and thats about it.

  12. #12
    The Red Reaper 98Z28importslayer's Avatar
    Join Date
    Feb 2008
    Location
    Spring hill, TN
    Posts
    210

    Red
    1998 Camaro Z28 T-Top A4

    Quote Originally Posted by Z28_06374 View Post
    These trannys are real sensitive how much fluid is in or not in them. Its best to run them 1/2 quart over (check hot). Oh and dont run synthetic...
    yeah i acutally put a extra 1/2 quart in and i used valvoline maxlife ATF which is the best stuff at autozone thats non synthetic. could it be shifting bad cause theres to much in there ???
    Last edited by 98Z28importslayer; 11-02-2008 at 06:02 PM.

  13. #13
    A 1/2 qt is fine but 1 qt over may be bad, oh and get some maf cleaner and clean that up believe it or not, the maf has alot to do with the tranny.

  14. #14
    The Red Reaper 98Z28importslayer's Avatar
    Join Date
    Feb 2008
    Location
    Spring hill, TN
    Posts
    210

    Red
    1998 Camaro Z28 T-Top A4

    Quote Originally Posted by Z28_06374 View Post
    A 1/2 qt is fine but 1 qt over may be bad, oh and get some maf cleaner and clean that up believe it or not, the maf has alot to do with the tranny.
    anything else i should check ?

  15. #15
    Just a souped up sunfire. Ryans99LS1's Avatar
    Join Date
    Jun 2007
    Location
    Parma Heights, Ohio
    Age
    27
    Posts
    891

    SOM
    99 Trans Am

    If you are interested in a trans cooler let me know, its a B&M and i only used it for like 4 months.

  16. #16
    The Red Reaper 98Z28importslayer's Avatar
    Join Date
    Feb 2008
    Location
    Spring hill, TN
    Posts
    210

    Red
    1998 Camaro Z28 T-Top A4

    I checked my fluid again today it did have about a quart in a half to much in so i took a quart out. I went out and drove for a good 30-40 mins and i still have the same issues the trans. seems to shift to reverse and everything better and still no problems at normal driving, even at 3/4 throttle i only have problems with 2-3, and at WOT it sometimes will shift fine 1-2, but still have issues with it bouncing off the rev. limter and always have problems with 2-3 at WOT with it just staying in 2 at 6000 rpms, so i let off and press back on the gas and it will still stay up there at 5-6k rpms, so ill let off again and get back in it then it will eventually shift. i still dunno wdf is wrong...

  17. #17
    Junior Member
    Join Date
    Feb 2006
    Location
    NH
    Age
    34
    Posts
    73

    Red
    2000 SS

    You could always try disconnecting the negative on your battery for 10-15 min to reset the computer. It simple and can't hurt.

  18. #18
    - STOCK ish - Sarge91's Avatar
    Join Date
    Apr 2008
    Location
    Fairhope, Alabama
    Age
    26
    Posts
    779

    Black
    2002 Camaro SS SLP

    When you fix the problem please do tell! I have had my tanny flushed, and put the stock tune back on, but sometimes my 1st to 2nd skips, not as bad as yours. I even tryed getting the dealer to fix it..

  19. #19
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Sounds to me like you have some serious internal transmission problems.

    Automatics don't like high RPM's to begin with, and it sounds to me like the clutch packs and/or bands are slipping under WOT at high RPM. When this happens, its basically like having the car in neutral, and you'll just bounce off the rev limiter until you let off the gas and the gear catches again.

    If I had to guess I'd say you're in for a trans rebuild, especially with 145K miles on it.

  20. #20
    Member Ramairgod's Avatar
    Join Date
    Sep 2005
    Location
    Spartanburg, SC
    Age
    33
    Posts
    122

    Red
    02 Pontiac Trans Am WS6

    ^ What he said... Trust me, its the only fix..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •