Results 1 to 5 of 5

4l80e no reverse

This is a discussion on 4l80e no reverse within the Automatic Transmission forums, part of the Drivetrain category; i Have 98 chevy truck 3/4 ton.has a 454 with a 4l80e tranny. reverse went out. still have all forward ...

  1. #1
    Junior Member
    Join Date
    Jul 2009
    Location
    TX
    Posts
    2

    Cool 4l80e no reverse

    i Have 98 chevy truck 3/4 ton.has a 454 with a 4l80e tranny. reverse went out. still have all forward gears. not slipping no other problems. No problem with reverse previously ....just all of a sudden went out all at once...can someone help figure this out..or have any suggestions ...i'm out of ideas

  2. #2
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    My linkage was jacked reverse was neutral, neutral was drive etc. I ran over a deer so that is what caused it for me. Is your car throwing a ses light?

  3. #3
    Junior Member
    Join Date
    Jul 2009
    Location
    TX
    Posts
    2
    no lights. linkage is fine every thing works perfect except reverse.been driving the truck for a while with no reverse

  4. #4
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Sounds like its time to shop for a rebuit trans.
    Google search "4L80e no reverse". I read a few things that say the rear band is probablly broken or worn out. Possiblly some over damage related to that also.

  5. #5
    Member fieropope's Avatar
    Join Date
    Jan 2009
    Location
    union mo
    Posts
    183

    white
    01 formula

    the reverse bands in those trannys have problems with the reverse band fracturing where it connects to the servo ,what this means is that the trans is doing everthing but gripping the drum when it is supposed to,the band can be changed but the trans has to come all the way apart.so yeah rebuild or replace only options


LinkBacks (?)

  1. 01-08-2013, 09:21 AM
  2. 12-20-2012, 04:20 PM
  3. 08-20-2012, 02:00 PM
  4. 05-07-2012, 02:58 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: 4L80e no reverse when hot
    By LOVonRUN in forum Automatic Transmission
    Replies: 2
    Last Post: 08-28-2012, 11:46 AM
  2. 4L80E tranny help
    By oldpurple73 in forum Automatic Transmission
    Replies: 0
    Last Post: 05-21-2011, 08:04 PM
  3. 4l80E help
    By oldpurple73 in forum Automatic Transmission
    Replies: 2
    Last Post: 03-05-2011, 08:27 PM
  4. WTB new/used lq9 6.0 and 4l80e
    By URLIFEWASOC in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 02-18-2008, 09:09 AM
  5. 4l80e
    By Bad30th in forum Western Members
    Replies: 45
    Last Post: 09-12-2007, 07:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •