Results 1 to 18 of 18

4l80 vibration

This is a discussion on 4l80 vibration within the Automatic Transmission forums, part of the Drivetrain category; Put a rossler built 4l80 trans and vig convertor and when the car gets to 70 mph it vibrates bad ...

  1. #1
    Junior Member
    Join Date
    Oct 2009
    Location
    Louisiana
    Posts
    9

    Pewter
    02 camaro

    4l80 vibration

    Put a rossler built 4l80 trans and vig convertor and when the car gets to 70 mph it vibrates bad any opinions?

  2. #2
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    Drive shaft out of ballance or tires.

  3. #3
    Junior Member
    Join Date
    Oct 2009
    Location
    Louisiana
    Posts
    9

    Pewter
    02 camaro

    Driveshaft been balanced have new tires

  4. #4
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Could be driveshaft angles out of wack.

  5. #5
    Junior Member
    Join Date
    Oct 2009
    Location
    Louisiana
    Posts
    9

    Pewter
    02 camaro

    think maybe an Adj torque arm would fix it?

  6. #6
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    yeah, probably.

  7. #7
    Senior Member qwkgto's Avatar
    Join Date
    Mar 2008
    Location
    OHIO"S only 9 second GTO
    Posts
    1,464

    Phantom Black Metalic
    2005 GTO

    what flexplate you using?

  8. #8
    Junior Member
    Join Date
    Oct 2009
    Location
    Louisiana
    Posts
    9

    Pewter
    02 camaro

    Stock

  9. #9
    Senior Member qwkgto's Avatar
    Join Date
    Mar 2008
    Location
    OHIO"S only 9 second GTO
    Posts
    1,464

    Phantom Black Metalic
    2005 GTO

    you have to use a spacer kit I beleive.

  10. #10
    Junior Member
    Join Date
    Oct 2009
    Location
    Louisiana
    Posts
    9

    Pewter
    02 camaro

    First I ever heard of that

  11. #11
    Senior Member qwkgto's Avatar
    Join Date
    Mar 2008
    Location
    OHIO"S only 9 second GTO
    Posts
    1,464

    Phantom Black Metalic
    2005 GTO

    I have a performabuilt 4l80 in my gto,there is a 4l80 specific flexplate out of a ls based chevy/gmc truck 6.0l I used,makes its a easy swap that and the converter is made to fit the ls style lugs on the flexplate as the 4l80s use 6 bolts instead of the normal 3 in the smaller transmissions converter/flexplate setups.

  12. #12
    Junior Member
    Join Date
    Oct 2009
    Location
    Louisiana
    Posts
    9

    Pewter
    02 camaro

    I'll have to check the car belonged to my friend I'll gave to see exactly what flexplate is in it do you have the part number for it?

  13. #13
    Junior Member
    Join Date
    Oct 2009
    Location
    Louisiana
    Posts
    9

    Pewter
    02 camaro

    Ok the convertor in the car Is the same convertor that was used with the 4l60 it was shipped back to vigilante and upgraded to a multi disc and made to work with the 4l80 so it still has 3 bolts

  14. #14
    Member fieropope's Avatar
    Join Date
    Jan 2009
    Location
    union mo
    Posts
    183

    white
    01 formula

    the converter may be modded wrong?? give VIG a call see what they think.

  15. #15
    Senior Member qwkgto's Avatar
    Join Date
    Mar 2008
    Location
    OHIO"S only 9 second GTO
    Posts
    1,464

    Phantom Black Metalic
    2005 GTO

    Quote Originally Posted by fieropope View Post
    the converter may be modded wrong?? give VIG a call see what they think.
    could be the cause,i broke one of their converters 4l80e and it vibrated bad!
    mods: custom built twins, built 408 w/l92 stock GM heads,GM matching intake,drag bags,frame ties,aluminum drive shaft, performabuilt 4l80e,Yank converter,ohios fastest and quickest 04-06 GTO 9.52 at 144mph. 1.50 60ft on stock rear end and shafts/suspension,on drag radials.

  16. #16
    Junior Member
    Join Date
    Oct 2009
    Location
    Louisiana
    Posts
    9

    Pewter
    02 camaro

    I don't think it's the convertor you can put it in neutral and rev it no vibrations

  17. #17
    Member fieropope's Avatar
    Join Date
    Jan 2009
    Location
    union mo
    Posts
    183

    white
    01 formula

    Quote Originally Posted by V6ls1 View Post
    I don't think it's the convertor you can put it in neutral and rev it no vibrations
    When its in nuetral there is no load on the converter which equals useually no noise. same as a stock converter when it goes out youll have no noise in neutral or park

  18. #18
    Member
    Join Date
    Oct 2009
    Location
    NorCal
    Posts
    260
    02 Z28

    same thing happend to mine.. idk if its the same because i have a 02 z28. at first i thought it was the tires. on mine, they were brand new, michelin pilot as plus. i figured they might have f'd up the alignment or some other shit. i went back and it was aligned perfectly. so i went home and put it on jacks. i pretty much just checked the driveshaft, u joint, differential... and when i came down to the tranny part i noticed that the mount was a little soaked in tranny fluid. i took it apart and there it was, a burnt up tranny mount. i changed that and while i was at it i flushed all the tranny fluid, put a new tranny filter, gasket, etc..

    after all that, no vibrations driving 70..80..90..100.. mph...

    im not sure about yours, but that fixed the vibrations on my car. id say just checked the tranny mount pull it out and see how its lookin.

    >edited because i thought you had a trans am... so now im pretty sure its your tranny mount bro. too much rubber gettin burnt.. hahaha

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 4l60 4l80
    By Joels1 in forum Automatic Transmission
    Replies: 2
    Last Post: 01-13-2010, 01:43 AM
  2. 4l80(85)e in 4thgen fbody
    By IT_SS in forum Automatic Transmission
    Replies: 0
    Last Post: 03-10-2008, 09:49 AM
  3. F/S 6.0l and 4l80
    By tahoebigah in forum Parts For Sale / Trade
    Replies: 7
    Last Post: 08-09-2007, 08:32 AM
  4. 4L60 to 4L80?Should I swap?
    By 35thZ28 in forum Automatic Transmission
    Replies: 3
    Last Post: 09-20-2006, 12:34 PM
  5. 4l80 question
    By possum398 in forum Drivetrain
    Replies: 3
    Last Post: 04-16-2006, 03:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •