Results 1 to 2 of 2

4l60e problem

This is a discussion on 4l60e problem within the Automatic Transmission forums, part of the Drivetrain category; I have a 99 camaro z28 and whenever i get on it hard it makes sort of a grinding type ...

  1. #1
    Junior Member Chevy Camaro z28's Avatar
    Join Date
    Oct 2009
    Location
    Indianapolis
    Posts
    1

    White and Black
    1999 Chevy Camaro Z28

    4l60e problem

    I have a 99 camaro z28 and whenever i get on it hard it makes sort of a grinding type noise. Its fine when your just driving around. No clue what it is but doesnt sound good. Please help.
    Clayton

  2. #2
    Member fieropope's Avatar
    Join Date
    Jan 2009
    Location
    union mo
    Posts
    183

    white
    01 formula

    sounds like the rear planet only time mine made a noise was when i was passing someone at about 100. then one day i staarted driving and i thought i was draggin my exhaust or something.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Strange problem (4L60E)
    By Itllrun in forum Automatic Transmission
    Replies: 4
    Last Post: 03-16-2010, 11:12 AM
  2. 4L60E Problem's?????
    By kaine806 in forum Automatic Transmission
    Replies: 14
    Last Post: 08-22-2009, 04:17 AM
  3. 4L60E shifting problem
    By shiftless in forum Automatic Transmission
    Replies: 4
    Last Post: 05-30-2008, 03:04 PM
  4. 4l60e shift problem
    By tds1213 in forum Automatic Transmission
    Replies: 3
    Last Post: 10-05-2007, 07:26 PM
  5. 4l60e problem please help
    By drperformance in forum Automatic Transmission
    Replies: 1
    Last Post: 07-07-2006, 06:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •