Results 1 to 3 of 3

1999 Trans am A4 Transmission going? Computer?

This is a discussion on 1999 Trans am A4 Transmission going? Computer? within the Automatic Transmission forums, part of the Drivetrain category; Hello, My wonderfull 99 A4 TA is giving me a bit of a stomach ache. When driving light on the ...

  1. #1
    Junior Member fakeWSsick's Avatar
    Join Date
    Jul 2008
    Location
    Wisconsin
    Posts
    10

    Midnight Blue
    1999 Pontiac Trans Am

    1999 Trans am A4 Transmission going? Computer?

    Hello, My wonderfull 99 A4 TA is giving me a bit of a stomach ache. When driving light on the gas (normal) it shifts very smooth at 2 to 2.5 RPMS. Unfortunatly sometimes while driving the TCS OFF light comes on and the car starts shifting at 3000 rpm insted of 2 even while still drving normally. Not only do I get shit MPG but i fear I may have tranny problems or something along those lines or something with the shift controller. Too bad i couldnt afford a M6. Any ideas? Thank you in advance, it means alot, im broke lol! By the way I don't really ever beat the car but have only had it for a month and has 99k miles so im not sure when things really start to go on the ls1 birds, first one. Previous owner prolly a dam kid, got from dealer.

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    *disclaimer I'm not a tranny expert. With that out of the way, It could be a few things from a bad sensor, do you have TCS?Or it could be the clutches going out. Pull the dip stick for the tranny and check the level and see what the fluid looks like. If it is brown and smells burnt I'm sorry but a rebuild will be in your future. IF there is a lot of particulate in it, something is letting or has let go.

    Also get a tranny cooler on that thing, the stock ones are less the adaquite on many levels.

  3. #3
    Member performabuilt's Avatar
    Join Date
    Jul 2006
    Location
    SUGAR LOAF PA
    Posts
    489

    blue
    2000ss

    Since it happens only after the light comes on I would get a scanner on its likley and electrical issue of some sort

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Firehawk transmission question
    By gtsleith in forum Drivetrain
    Replies: 16
    Last Post: 05-03-2016, 04:05 AM
  2. transmission and computer not communicating correctly
    By bvar20 in forum Computer & Tuning
    Replies: 3
    Last Post: 05-04-2012, 07:35 AM
  3. 2001 trans am computer into 1999 Z28
    By 99maroz28 in forum Computer & Tuning
    Replies: 3
    Last Post: 05-27-2011, 10:49 AM
  4. transmission, computer or Rear End?
    By camaross9810 in forum General Help
    Replies: 12
    Last Post: 03-30-2011, 11:43 AM
  5. 1999 Camaro Z28 6-speed Manual Transmission For Sale
    By Blackbeast99 in forum Vehicles For Sale / Trade
    Replies: 6
    Last Post: 04-16-2008, 07:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •