Results 1 to 10 of 10

02 camaro z28 tranny

This is a discussion on 02 camaro z28 tranny within the Automatic Transmission forums, part of the Drivetrain category; so i found out it wasnt the gaskets thats jacked up. it was the tranny housing. the rear tranny housing ...

  1. #1
    Member
    Join Date
    Oct 2009
    Location
    NorCal
    Posts
    260
    02 Z28

    02 camaro z28 tranny

    so i found out it wasnt the gaskets thats jacked up. it was the tranny housing. the rear tranny housing that goes with the drive shaft. that shit has a crack on it. so i wasted $$ because i bought trans fluid and trans filter. my fault that i didnt clean out all the dirt away before i went to work. but oh well.

    * does anybody here have a good tranny for sale? or does anybody here know where to get one?

  2. #2
    Member
    Join Date
    Mar 2007
    Location
    NC
    Posts
    421

    NBM
    1998Z28

    The 4L60E has 3 housings. I way I know is when I bought a Level 2 from Performabilt all I got was the center section. I had to take off the bell and tail sections off the stock one. So if all you busted was the tail housing you should be able to replace just that piece.
    TSP 347 SB, TSP Stage 2.5 PRC LS6, TSP MS4, Performabuilt Stage 2 4L60E, Yank PT4000, 4.11s, Fast 90/90, FTRA Cold air intake+all the free mods, Dynatech Supermaxx Exaust System, DMH Cutouts, Hooker Catback/FTRA Tips. Tuned by RPM/Garner NC. 11.28@119

  3. #3
    Exalted Cyclops 67CamaroRSSS's Avatar
    Join Date
    Feb 2007
    Location
    San Diego, CA
    Posts
    5,824

    2002 Z28 A4 NBM
    Sadly now demodded :(

    The tail housing on the 4l60E, especially where the torque arm mounts, is a weak link in the system for any modified car. If you can, buy a body mount adjustable torque arm and replace it when you replace the tailshaft. This will take beaucoup stress off of the tranny.

  4. #4
    Member
    Join Date
    Oct 2009
    Location
    NorCal
    Posts
    260
    02 Z28

    good stuff fellas. good lookin' out! so i went to my friends dad's transmission shop and he said welding would do it.. well i was like, hmmmm NO. haha id rather know that i have something that will hold up then worrying about when that shit will break down.

    anyways, i did go to a junkyard nearby and found an 02. a wrecked one. so i had them lift that sucker up and i went to town. the tail housing looks great. just alot of thick dried grease, dirt, etc. so i went to work and used our sandblaster, polished it, and now it looks brand new. i went to and sprayed it with this inspection spray we got that shows cracks when you hit the lights. no leaks.. so now i got myself a brand used brand new tail housing for $30. bargained! and went to the dealer and got myself a new transmission mount. that was $120. boo!

    this weekend im goin to work on it put my exhaust back on etc. etc. fill her up with new tranny fluid etc etc... when im done ill most likely have a pic and deff a video!

    and ill look that body mount adjustble torque arm..
    Last edited by vonskeezy28; 10-20-2009 at 10:56 PM. Reason: had to add that last sentence! ^^^^

  5. #5
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Entered this thread late in the game, so what went wrong in the first place?

  6. #6
    Member
    Join Date
    Oct 2009
    Location
    NorCal
    Posts
    260
    02 Z28

    heres what happend......

    friday night, i went to pick up 8 brand new michelin pilots rs for my stocks.
    same friday night, i lost those 4 new tires by burnin them. i even switched the fronts to the back and put in new 2 tires in the front.

    saturday morning, woke up went to ihop. as soon as after i parked my car next thing you know smoke was coming out from the bottom. i looked under and it was a leak hittin the exhaust pipes. wasnt any major smoke or anything so i decided to just eat first cause i wanted my damn pancakes man. haha

    i went out and i there was a major leak. i noticed it came from the trans pan cuz it was alot of fluid on the trans pan. went straight home and got it on jacks. i figured something would have went wrong because i was dogging the hell out of it the night before.

    so i bougt tranny filter and gasket and lots of fluid thinkking that was problem. took it apart, gasket looks clean, so i was like f*ck it. i already bought the stuff..

    so i replaced the filter, gasket. locked it, tightened it, added the fluid.. then started it.. i let it start for a whole 30 minutes on park chillin. went back and there it was again. after going throught all that process i knew it was something wrong with the 1 of the housing. i just prayed that it wasnt the housing that i f'd up.

    im good now tho. =]

  7. #7
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Damn glad you got it sorted out, I fear when my day comes.

  8. #8
    Member
    Join Date
    Oct 2009
    Location
    NorCal
    Posts
    260
    02 Z28

    haha. thanks man. id like to say it wont happen to you, but you already know it will come. i stay in vallejo man. what part of the bay are you from?

  9. #9
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Quote Originally Posted by vonskee-z28 View Post
    haha. thanks man. id like to say it wont happen to you, but you already know it will come. i stay in vallejo man. what part of the bay are you from?
    Livermore, there is a car show every Friday in concord at the baja fresh in the sun valley mall. These past two weeks have been surprisingly good so of course I expect this week to be slow It is hosted by an older group with hotrods but is strictly american muscle show is roughly from 5:30 till dark, no one really shows up till after 6pm. Usually a few of the local lsx people bum around there for awhile.

  10. #10
    Member
    Join Date
    Oct 2009
    Location
    NorCal
    Posts
    260
    02 Z28

    that sounds dope. ill see what i can do.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 1995 z28 Camaro tranny
    By J_trizzleLS1 in forum Automatic Transmission
    Replies: 1
    Last Post: 05-23-2010, 12:57 PM
  2. 95 3.4 camaro a4 tranny... same as all other 4l60e
    By eddielb in forum Automatic Transmission
    Replies: 2
    Last Post: 06-16-2008, 03:04 PM
  3. wtb: 6speed tranny for lt1 93 camaro
    By slimjim69619 in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 05-10-2008, 06:39 PM
  4. Parting out 94 LT1 Camaro! No engine/tranny
    By Redirwol1 in forum General Classifieds
    Replies: 1
    Last Post: 05-27-2007, 08:04 PM
  5. WTB Auto Tranny for 99 Camaro SS LS1
    By ls1luver in forum Parts Wanted / Trade
    Replies: 1
    Last Post: 05-09-2007, 03:37 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •