Results 1 to 8 of 8

Y pipe wont fit/go together?

This is a discussion on Y pipe wont fit/go together? within the External Engine forums, part of the LSx Technical Help Section category; Have any of you guys that have done Long Tube headers had problems of the Y pipe fitting. If so ...

  1. #1
    Member
    Join Date
    Dec 2007
    Location
    Minnesota
    Posts
    196

    pewter
    2002 Tans am WS6 M6

    Y pipe wont fit/go together?

    Have any of you guys that have done Long Tube headers had problems of the Y pipe fitting. If so what did you do? My situation is I bought JetHot long tubes and a texas speed Y. Headers went on good but the Y doesn't seem right. One part seems to long and slighlty under bent other the Y part doesn't want to fit under the tunnel brace or line up with the exhaust. Any help or input would be great!

  2. #2
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Quote Originally Posted by Richy_Rich67 View Post
    Have any of you guys that have done Long Tube headers had problems of the Y pipe fitting. If so what did you do? My situation is I bought JetHot long tubes and a texas speed Y. Headers went on good but the Y doesn't seem right. One part seems to long and slighlty under bent other the Y part doesn't want to fit under the tunnel brace or line up with the exhaust. Any help or input would be great!
    Thats the exact setup I have, didn't have any problems with it. Do you have some pictures, maybe that will help to diagnose the problem.

  3. #3
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    how bout some pics of a TSP ORY that ..........DID fit ........the new style that is.....

  4. #4
    Member
    Join Date
    Dec 2007
    Location
    Minnesota
    Posts
    196

    pewter
    2002 Tans am WS6 M6

    ill see what I can come up with. The last time I tryed to load some pictures up to this site it just would'nt work.

  5. #5
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by Richy_Rich67 View Post
    ill see what I can come up with. The last time I tryed to load some pictures up to this site it just would'nt work.
    you need to have them hosted through photobucket or etc....also i believe there is a post limit in affect also that needs to be reached before you can post pics...(i think)

  6. #6
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by Richy_Rich67 View Post
    ill see what I can come up with. The last time I tryed to load some pictures up to this site it just would'nt work.
    Posting pictures sticky

  7. #7
    Hide ya kids Hide ya wife 94ss06gxp's Avatar
    Join Date
    Nov 2009
    Location
    Shepherd MI
    Posts
    119

    Silver, Stealth Gray
    97 SS CLONE, 06 GP GXP

    shady is it like how you had to get the y pipe shortend because the headers made it too long?

  8. #8
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by 94ss06gxp View Post
    shady is it like how you had to get the y pipe shortend because the headers made it too long?
    the only reason that was ..is because of my cut out i believe.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: car wont start and now gauges wont work!
    By AB'sLs1 in forum General Help
    Replies: 52
    Last Post: 04-20-2013, 09:54 PM
  2. erg pipe to intake, bolt wont backout!
    By ggino85 in forum General Help
    Replies: 4
    Last Post: 07-03-2011, 12:33 PM
  3. bought pacesetter longtubes/tsp y pipe. wont fit?
    By jmatt07 in forum External Engine
    Replies: 3
    Last Post: 03-26-2009, 04:10 AM
  4. For Sale: Bassani y-pipe and cat delete pipe
    By Soltakr in forum Parts For Sale / Trade
    Replies: 19
    Last Post: 08-07-2008, 09:32 PM
  5. H pipe Vs. X pipe (You Make the choice for me)
    By 180ls1 in forum External Engine
    Replies: 41
    Last Post: 10-26-2007, 08:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •