Results 1 to 11 of 11

Where to go !!!

This is a discussion on Where to go !!! within the External Engine forums, part of the LSx Technical Help Section category; Well i have the mods that are in my sig, if it doesnt show up here it is. I have ...

  1. #1
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    Where to go !!!

    Well i have the mods that are in my sig, if it doesnt show up here it is. I have 4.10's, Gutted Cats, Exhuast Cutout, Hooker Muffler, SLP Lid, K&N Filter, Smooth Bellow, Throttle Body Bypass, Throttle Body Ported, Underdrive Pulley, 160 Thermo and LSx Tune. Ive had the car for about 2 months now and it pulls really good on the top end just lacks a bit of low end grunt meaning TQ that im use to with my LT1's but overall it has more RWTQ so im not worried especially after i install the gears. Couple of parts up top are not installed yet but will shortly, im trying to figure out if its worth taking it to a dyno shop and were? also i live close to Glendale, CA. I use to take my car to Haddarmotorsports but thats a bit of a drive is there anyone thats a bit closer that gives good rates?

  2. #2
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    Quote Originally Posted by karpetcm View Post
    Well i have the mods that are in my sig, if it doesnt show up here it is. I have 4.10's, Gutted Cats, Exhuast Cutout, Hooker Muffler, SLP Lid, K&N Filter, Smooth Bellow, Throttle Body Bypass, Throttle Body Ported, Underdrive Pulley, 160 Thermo and LSx Tune. Ive had the car for about 2 months now and it pulls really good on the top end just lacks a bit of low end grunt meaning TQ that im use to with my LT1's but overall it has more RWTQ so im not worried especially after i install the gears. Couple of parts up top are not installed yet but will shortly, im trying to figure out if its worth taking it to a dyno shop and were? also i live close to Glendale, CA. I use to take my car to Haddarmotorsports but thats a bit of a drive is there anyone thats a bit closer that gives good rates?
    sounds like your about ready for heads and cam

  3. #3
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    Well will see about the heads and cam, i might just put on nitrous to last me a while and then ill probably go that route. Not sure yet but hopefully i can put up atleast 320+rwhp on the dyno with what i got so far.

  4. #4
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    A tune would wake it up a bit although i would wait until you decide to go with a cam or even a full exhaust.
    Also i would ditch the K&N filter and just pick up a stock paper filter, works better and flows the same.
    J
    2001 SS, Its not the car its the Driver that matters....

  5. #5
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    Ya your right about the filter i think i still have my stock one. My car is pinging pretty bad as we speak above 4k. Ive cleaned the MAF pretty good with MAF cleaner but still has a ping to it. Ive added octane booster but still the ping is there, i think once i get that issue sorted out ill get to work on the other detailes.

  6. #6
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    Quote Originally Posted by karpetcm View Post
    Ya your right about the filter i think i still have my stock one. My car is pinging pretty bad as we speak above 4k. Ive cleaned the MAF pretty good with MAF cleaner but still has a ping to it. Ive added octane booster but still the ping is there, i think once i get that issue sorted out ill get to work on the other detailes.
    please save your money and don't buy octane booster......when they say you gain 2 octane points they really mean .2 if you are running 93 it will only bump you up to 93.2 octane.
    what grade of fuel are you running now? if anything get the highest grade at the pump...if that doesn't do it for you, then call around and you should beable to find 100 octane unleaded race fuel to mix with your high test.
    most winter blend gas has more methanol added to it that will make you lose 2-3 mpg and not run as well acrossed the board

  7. #7
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    also try unplugging your MAF and running it for a day or so....your ses light will come on, but car will run....see if your ping goes away

  8. #8
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    If i unplug the MAF and drive the car around can i floor it above 4k to see if it still pings or will it cause damage to the motor. Im using the highest grade we have here in cali which is 91 octane the MAF has been cleaned with MAF cleaner several times very well so i dont know what the exact cause is but it will come and go. The car idles just fine no issues there, the car when it doesnt ping though pulls insane in the top end. I think it came a bit lean from the factory, my 01 SS i had would not pull as well in the top end as this car does but im sure the difference isnt that great between the 2 cars.

  9. #9
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    Quote Originally Posted by karpetcm View Post
    If i unplug the MAF and drive the car around can i floor it above 4k to see if it still pings or will it cause damage to the motor. Im using the highest grade we have here in cali which is 91 octane the MAF has been cleaned with MAF cleaner several times very well so i dont know what the exact cause is but it will come and go. The car idles just fine no issues there, the car when it doesnt ping though pulls insane in the top end. I think it came a bit lean from the factory, my 01 SS i had would not pull as well in the top end as this car does but im sure the difference isnt that great between the 2 cars.
    yes you can run it with out the MAF, it throws itself into speed density mode, and goes by your main PE tables and MAP sensor.....but with or with out the maf its your car is running lean you can get detonation, burned pistons, or burned valves, hopefully your motor is getting a bad signal from the MAF and with it unplugged it will run better(safer) till you can replace the MAF.
    look really good in the MAF to make sure none of the small wires that run acrossed the center aren't broken....
    lean does make more power, till it gets too lean, thats when things melt.

  10. #10
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    Thanks Mark21742, i did check the wires very carefully and none are broken and the wires look realy clean no signs of dirt or dust. Ill go a bit richer up top with a tune and if that doesnt work either ill change the MAF its about 129.00 AC Delco unit. Ill first try unplugging the MAF and testing it the way you said and see what happens.

  11. #11
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    Just went and purchased a Fram paper filter for my Z and took out the K&N, waiting on my computer to get back after a re tune. If the car still pings im gonna purchase a MAF and i should be good to go. Ill take it to the dyno in a couple of weeks and see what it puts down, do you guys know of any good shops here in southern cali, los angeles area that does rear ends. If you guys do please let me know

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •