Results 1 to 4 of 4

Weird Coolant problem

This is a discussion on Weird Coolant problem within the External Engine forums, part of the LSx Technical Help Section category; I have a 1994 3.4L V6 camaro. When i crank my car, coolant immediatly starts running down on the right ...

  1. #1
    Junior Member
    Join Date
    Nov 2006
    Location
    Jacksonville, FL
    Age
    29
    Posts
    4

    Green
    1994 Camaro V6

    Weird Coolant problem

    I have a 1994 3.4L V6 camaro. When i crank my car, coolant immediatly starts running down on the right side of the car, down the power steering pump. It runs down the bottom of the pump and onto the ground. Its not a hose, i just replaced all the hoses. What could it be? Freeze plug maybe? Help appreciated.

  2. #2
    Visualize°Design°Create SSwt00SS's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, TX
    Posts
    9,287

    '12 Silver SS 1SS
    '00 Black SS #8617

    did it leak before you changed hoses? if not, then it's the hoses. check and make sure they are sealed completely. also, check the weep hole on your water pump to make sure you aren't leaking from there (water pump starting to fail)

  3. #3
    We'll be back... GatorSS's Avatar
    Join Date
    Aug 2005
    Location
    THE SWAMP
    Posts
    1,446

    Light Pewter Metallic
    2000 Camaro SS M6

    I'd first make sure all your clamps are tight.

  4. #4
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    34
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    It can't really be too wierd, it's coming from somewhere. The places it could be coming from are limited if it starts pumping it out of the engine as soon as you start it before it warms up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird problem I've never had before...
    By SajoR in forum Camaro / SS
    Replies: 5
    Last Post: 05-25-2009, 09:33 PM
  2. weird problem!
    By barryz in forum General Help
    Replies: 3
    Last Post: 05-24-2009, 12:14 PM
  3. Weird coolant leak
    By deadboltmk in forum V6
    Replies: 1
    Last Post: 12-21-2006, 10:08 AM
  4. Need a little help here weird problem
    By 98Roadster6speed in forum Corvette
    Replies: 3
    Last Post: 09-29-2005, 04:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •