Results 1 to 11 of 11

water pump & t-stat woes...

This is a discussion on water pump & t-stat woes... within the External Engine forums, part of the LSx Technical Help Section category; When i went to swap my 160* stat onto the new w/p, it wont go in cause the opening for ...

  1. #1
    slammed RAWPWR3's Avatar
    Join Date
    Aug 2005
    Location
    under the car cover
    Age
    29
    Posts
    375

    M.R.M. & C.E. Yellow
    01 TA & 02 CETA

    water pump & t-stat woes...

    When i went to swap my 160* stat onto the new w/p, it wont go in cause the opening for the t stat on the new water pump is smaller, and the old t stat has the two little towers that hold the spring in place. The new pump came with a new thermostat, but its the factory rating. I ground down the little towers on the old stat, but its just shy of going in. I cant take any more material off of the towers, i was thinking of notching the opening on the w/p, but i really dont want to. My other option would be to get a new thermostat for the new housing that came with the pump, but it would just have to be the stat, cause the new housing is different. So, does anyone know where i can get said stat in 160* rating, or should i just notch my new ac delco 200 dollar w/p. Ill try and get some pics up later so yall can see what im talking about.

    Thanks,
    YMN

    EDIT: While i have youre attention, i would like to get some more opinions on whether or not i should use sealant on the new gaskets. Ive done a search and the majority say yes, yet a few say no. I honestly dont see the need for it, this is a machined alluminum surface were dealing with here, and the gaskets are metal with oring inserts. This isnt some sh!tty 1st gen sbc were talikng about here. Not to mention, it didnt have any when i removed them so the general didnt think it was necessary either. Although...it is better to be safe than sorry. Let me know what you guys think.
    Last edited by RAWPWR3; 04-01-2009 at 03:47 PM.

  2. #2
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    what brand thermostat? also i would still you some like maybe hylomar. it never really dries (so you dont have to worry about cracking from the heating and cooling process) but creates a great seal. that what i use on all of my stuff and never had any problems. Also i wouldnt cut into that water pump because if you mess it up, there goes $200. good luck

  3. #3
    slammed RAWPWR3's Avatar
    Join Date
    Aug 2005
    Location
    under the car cover
    Age
    29
    Posts
    375

    M.R.M. & C.E. Yellow
    01 TA & 02 CETA

    I believe my 160* stat is a hypertech. It says "motorad" on it and "germany". Thanks

  4. #4
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Quote Originally Posted by RAWPWR3 View Post
    I believe my 160* stat is a hypertech. It says "motorad" on it and "germany". Thanks
    i just ordered a hypertech so i will let you know if it fiits. i think motorad is its own company

    http://www.motoradusa.com/products/t...ent/index.html

  5. #5
    slammed RAWPWR3's Avatar
    Join Date
    Aug 2005
    Location
    under the car cover
    Age
    29
    Posts
    375

    M.R.M. & C.E. Yellow
    01 TA & 02 CETA

    Thats a cool link, my thermostat is the one on the top left corner. I might have ordered it from ws6store or TR, i dont remember now.

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by RAWPWR3 View Post
    I believe my 160* stat is a hypertech. It says "motorad" on it and "germany". Thanks
    Interesting... the 180 degree thermostat I purchased from our local Autozone was also a Motorad, with manufacturing stamps from Germany and Israel.

  7. #7
    slammed RAWPWR3's Avatar
    Join Date
    Aug 2005
    Location
    under the car cover
    Age
    29
    Posts
    375

    M.R.M. & C.E. Yellow
    01 TA & 02 CETA

    Heres those pics...




  8. #8
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    r u gunna use that shinny new one?

  9. #9
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    The pictures help alot. You ahve a new style pump. You need one of these to replace the 195 t-stat you have.

    http://www.ws6project.com/user_stor/...7e69d6a04c71a8

    Also use a sealant called right stuff. It's made by permatex.

  10. #10
    slammed RAWPWR3's Avatar
    Join Date
    Aug 2005
    Location
    under the car cover
    Age
    29
    Posts
    375

    M.R.M. & C.E. Yellow
    01 TA & 02 CETA

    Yeah i guess im gonna have to until i can find a 160 thermo thatll fit into that housing. At least its gonna look good, but now this housing doesnt have an extra tab where i can attach the wire harness for the a/c compressor like the old one did. Damn i complain alot, lol. Im just gonna finish it up tomorrow cause ive gotta go out of town friday afternoon, and ill be gone for a whole week. I cant wait to drive that thing tomorrow, its been awhile since ive taken her out. That six speed is calling my name... Thanks again for youre help bro.

  11. #11
    slammed RAWPWR3's Avatar
    Join Date
    Aug 2005
    Location
    under the car cover
    Age
    29
    Posts
    375

    M.R.M. & C.E. Yellow
    01 TA & 02 CETA

    Quote Originally Posted by thearborbarber View Post
    The pictures help alot. You ahve a new style pump. You need one of these to replace the 195 t-stat you have.

    http://www.ws6project.com/user_stor/...7e69d6a04c71a8

    Also use a sealant called right stuff. It's made by permatex.
    F@$kin aye man, thanks alot thats it! Im gonna order one right now. It makes me feel kind of special having fancy new '04 parts on my old skool circa '02 EL S Juan. Yeah i got some of that permatex in the garage from when i did the water pump on my bbc. I just didnt think it would be necessary on something like this, but i guess its better to be safe that sorry. Thanks again fellas.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pump woes
    By finkle745 in forum General Help
    Replies: 17
    Last Post: 03-30-2015, 06:03 AM
  2. water pump
    By blackTA6585 in forum General Help
    Replies: 7
    Last Post: 09-03-2010, 07:41 PM
  3. water pump
    By Pete Rock98 in forum General Help
    Replies: 25
    Last Post: 05-17-2009, 02:46 PM
  4. help on water pump please
    By Cohi in forum General Help
    Replies: 19
    Last Post: 03-26-2009, 08:23 AM
  5. Do electric water pumps pump enough water for daily use?
    By xinthenight in forum External Engine
    Replies: 6
    Last Post: 08-02-2007, 10:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •