Results 1 to 11 of 11

Very annoying squeak!

This is a discussion on Very annoying squeak! within the External Engine forums, part of the LSx Technical Help Section category; ...

  1. #1
    Member raysz28's Avatar
    Join Date
    Sep 2005
    Location
    Central Ohio
    Posts
    180

    Ticket Red
    M6 1998 Z-28

    Very annoying squeak!

    Hey guys, so on the Hot Rod Power Tour a few weeks ago i started having a bad squeak from the front drive accessories. The day before we left for the tour I swapped the Power steering pump. It worked fine for a day…then the squeak started at 2500 RPM. By the end of the tour it was squeaking at idle…LOUD. Its coming from the drivers side right around the PS pump…
    I made it home and got a TURN ONE power steering pump and installed it. The squeak came back a day later.
    So then I started replacing the idle pullies…replaced the tensioner idle pulley which took the squeak away for a day.
    I took the AC pulley off (didn’t replace it because it was special order), cleaned it and loaded it up with WD40 and reinstalled it. The squeak yet again went away for a day….
    So today I picked up the second pulley today and installed it…nothing! Still squeaks! And I didn’t even get the day squeak-free!

    Now what?! It only leaves the AC and water pump left to replace…and I don’t want to replace them to find out if it’s the problem…but I will if I have to…

    Thoughts??

  2. #2
    Royal pain in the.... Phantom2kz's Avatar
    Join Date
    Aug 2007
    Location
    savannah, ga
    Posts
    159

    2001 Z-28 A4 NBM
    2002 35th anni SS M6#1696

    old belt or new belt?
    possible leak from water pump/gasket on to belt
    out of alignment pulleys/pulley on too far ,happens on P/S pumps.
    check run-out on crank balancer.
    Good luck

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I had a set of Kelly belts on a DD a few years ago that always squeeked. I could quite it down with belt dressing for a few days at most. Finally just yanked them and put another brand set of belts on -- problem solved.

    The tensioner spring could also be getting weak and allowing belt slippage. I'd shoot it with belt dressing to see if the noise goes away. That would rule out your remaining two pumps as being the culprits. Then either check your tensioner or simply try a different belt.

  4. #4
    Member raysz28's Avatar
    Join Date
    Sep 2005
    Location
    Central Ohio
    Posts
    180

    Ticket Red
    M6 1998 Z-28

    belt is new also.
    i did a little research in my Haines repair book, and it said that the water pump could be the most likely culprit. i am not leaking any fluid from the weep hole but the high pitch squeak fits the description. the book said if it squeaks, the shaft has failed.
    the car never over heats but the low coolant light comes on sometimes (coolant is full.)
    Think its the Water pump??

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by raysz28 View Post
    belt is new also.
    i did a little research in my Haines repair book, and it said that the water pump could be the most likely culprit. i am not leaking any fluid from the weep hole but the high pitch squeak fits the description. the book said if it squeaks, the shaft has failed.
    the car never over heats but the low coolant light comes on sometimes (coolant is full.)
    Think its the Water pump??
    The sensor in your overflow tank is probably malfunctioning -- check the level and if it is ok, that has to be why the light is triggered. Still won't hurt anything to shoot it with belt dressing as a quick check. My Kelly belts squealed from the day I installed them.

  6. #6
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    I was fighting a belt squeal on my Grand Prix the other day.

    A heater hose blew, and sprayed coolant directly into the alternator and all over the belt.

    So I fix the hose, and I have a horrible bearing squeal. I remove the belt, spin the pulleys, and the alt bearing is cooked...coolant sprayed directly inside it. FML. So I get a new alt, but something still screams while running.

    Check all the pulleys again, they are all good. Spray the belt with brakeclean while running, squeal stops for a sec and start again. So I pull the belt back off and go get a new one. Quiet as a mouse now. I think what happened was the belt got contaminated by coolant, which was causing it to make the horrible squeal.
    1998 Trans Am WS6 SGM
    Lid, Pro 5.0, WS6 Short Stick, LS7 Clutch, TB Bypass, Detroit TrueTrac, Poly Mounts, Bilstein Shocks, LS6 Intake, SFCs, CTS-V Brake Upgrade, STB, Nitto 555's. SS Longtube Headers and True Duals w/ H pipe and Magnaflows. Tuned by Harris Speed Works. 341.4WHP/346.1 lb/ft.

  7. #7
    Member raysz28's Avatar
    Join Date
    Sep 2005
    Location
    Central Ohio
    Posts
    180

    Ticket Red
    M6 1998 Z-28

    So, i just replaced the water pump with no improvement to the squeaking problem...
    I mostly frustrated that i cant figure out what the problem is and that i have bought parts that didnt fix it, not how much time i have spent fixing it...

    any other suggestions???

  8. #8
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by raysz28 View Post
    So, i just replaced the water pump with no improvement to the squeaking problem...
    I mostly frustrated that i cant figure out what the problem is and that i have bought parts that didnt fix it, not how much time i have spent fixing it...

    any other suggestions???

    Sell me the car for $100 -- I'll learn to live with the squeak. Seriously, did you try a different belt?

  9. #9
    Member raysz28's Avatar
    Join Date
    Sep 2005
    Location
    Central Ohio
    Posts
    180

    Ticket Red
    M6 1998 Z-28

    yes brand new belt was done before the a few weeks ago

  10. #10
    Royal pain in the.... Phantom2kz's Avatar
    Join Date
    Aug 2007
    Location
    savannah, ga
    Posts
    159

    2001 Z-28 A4 NBM
    2002 35th anni SS M6#1696

    The day before we left for the tour I swapped the Power steering pump. It worked fine for a day…then the squeak started at 2500 RPM. By the end of the tour it was squeaking at idle…LOUD. Its coming from the drivers side right around the PS pump…
    I made it home and got a TURN ONE power steering pump and installed it. The squeak came back a day later.

    still sounds like the P/S pulley might be on too far or not enough,
    is the belt aligned. is the belt wearing/freying at one end or the other?
    also make sure pulley is not cracked. pick up the frt end and try to hear it at crankshaft to make sure it is not a balencer issue, but sound like a P/S thing to me....

  11. #11
    Member raysz28's Avatar
    Join Date
    Sep 2005
    Location
    Central Ohio
    Posts
    180

    Ticket Red
    M6 1998 Z-28

    Thanks,
    you were right, the PS pulley was not on far enough.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. annoying
    By 99ss in forum Camaro / SS
    Replies: 28
    Last Post: 02-18-2010, 03:14 PM
  2. Question: annoying squeak
    By TAallday in forum Manual Transmission
    Replies: 1
    Last Post: 09-28-2009, 06:51 PM
  3. 08 Vette Procharger annoying belt squeak?
    By Joe00SS in forum Forced Induction
    Replies: 15
    Last Post: 06-11-2009, 01:12 AM
  4. Help: very annoying
    By wanna_lS1 in forum Firebird / WS6
    Replies: 2
    Last Post: 11-19-2008, 11:50 AM
  5. So annoying!!!!
    By TempleU_WS6 in forum Almost Anything Goes
    Replies: 46
    Last Post: 02-15-2008, 07:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •